WebPositive problem doesn't open HAIKU community web page

No web page can be opened on WebPositive.
Not even the official HAIKU community !
the same SSL peer certificate error message
appears on any web page i try to open

(i wrote this post, using gnome web)

Check if the time and date is set correctly on your computer.


You were right extrowerk!
I corrected the time and it worked.
WebPositive opens diaspora, mastodon, pixelfed and venera social
quite fast,
but… punishes facebook, which is crawling slow.

By the way,
why do I need to join my wifi
(though my credentials are stored)
& set the time every time I start HAIKU?

Or, I suppose i expect too much from an 2007 HP laptop,
on which I’ve installed HAIKU.

You need to buy a new internal C32-battery which is important for storing date and time on the computer.

1 Like

I have forgotten completely the internal C32-battery !!!

the nice surprise about WebPositive is that it only needs 327MB of memory (with two tabs running )

Until you get your battery replaced, other way to adjust automatically the time & date is the following:

Right click on the deskbar clock:

And click on “Syncronize” button:


You can also run Time --update from a Terminal. Theoretically this should happen on boot (hence “Synchronize at boot” in that screenshot) but I guess it still doesn’t…


Thanks for the information! Yes, for some reason, at least for me, the “Synchronize at boot” don’t work. I always need to synchronize manually because time-zone differences.

1 Like

Me, too. I need to click the wifi first, and then preferences, time, network time, only then, does the clock shows GREECE TIME (my time zone GMT + 2)
Then webPositive works fine, on most sites.

Might be good to enter a bug report for that if there isnt already one.

Is it not working at all or is it syncing but with a shift? In the later case, you could try to set another ntp server… Perhaps ru.pool.ntp.org would work better for you?

The sync on boot isn’t working because the network is disconnected, because the keystore for the wireless key has the ‘wrong’ time presumably. Catch 22, the fix is replacing the battery - which can be very tricky on a laptop.


What time are you referring to? The keystore just stores the wifi name and the wifi password?

Why would that be? If it syncs with a noticeable shift, most likely you have not set the correct timezone in locale preferences or the correct setting for dual booting with other systems (Windows does not use the hardware clock in the same way as everyone else). The NTP servers are all synchronized within a few microseconds of each other, there really is no need to select a different one.

Yes, I agree, it’s really a Catch 22 situation.
But it isn’ t too bothersome to do a couple of clicks.
Especially, when HAIKU has actually resurrected this old laptop of mine… from the dead.