Webpositive in nightly builds


I don’t understand why the nightly builds have the TV application or the teapot GL demo which are pretty useless (even if the teapot is cool), and not webpositive, which is essential for using a modern OS connected to internet.

installoptionalpackage -a webpositive

…is your friend.

It is not included in the nightly image due to size concerns. WebPositive is massive compared to the apps you mention and can be easily installed by the ‘installoptionalpackage’ script.

thank you.

Anyway, I first typed installoptionalpackage -l to see if it was available, but I couldn’t find it in the list.
I can now see it in my default alpha 2 installation, but not in the nightly build, well I’ll double check but I’m quite sure it wasn’t listed.

I don’t understand why installoptionalpackage -a doesn’t list available packages like it used to.

installoptionalpackage -f .
the -a option is to install a package with its deps.

I am using vmware and the boot drive even when first installed is filled to capacity with the nightly build. So it won’t install webpositive.

I have a secondary 2GB drive mounted, yet I don’t know how to point installoptionalpackage to the 2GB drive. Is there a way to install webpositive on the 2GB drive?

Best solution. Use Haiku’s installer & install Haiku to your 2GB drive. Then use that. =)

I don’t think there is a way to get it to download & install to your 2GB drive otherwise.

Thanks for the reply!

However, there might be some confusion. It sounds like you are saying to install to a real drive. Unfortunately, I don’t have a spare pc. I am trying to run it with vmware. The Haiku drive image only has 500MB and only has a few MB free space. The empty 2GB drive is the empty bfs harddrive image that comes with the nightly haiku vmware build.

What I did try to do as a work around was run the alpha2 in vmware since it has webpositive preinstalled. Copied over everything from the haiku boot drive image to the 2GB drive image. Then swapped out the 2GB drive that comes with the nightly with the loaded drive that now has Webpositive.

Didn’t work. It looks like Webpositive is looking for libraries in the Haiku drive instead of the 2GB drive. Even though the 2GB drive has those libraries. I tried copying over some missing lib files into /boot/system/lib/ but now it still can’t find curl no matter what I do.

Unless there is something I am overlooking (very likely), I will have to stick with the Alpha2.

Setup a VMWare machine with two virtual hard drives:

  1. One with an Haiku built vmware disk image, ideally a nightly/recent one, set as boot disk
  2. One with nothing (yet) on it, set a secondary disk. Size it according to your will (10Gb for instance)

Boot this VM. This should boot to Haiku, as usual.

  1. Run DeskBar > Preferences > DriveSetup, localize your secondary disk and create a BFS partition on it, taking the whole space.
  2. Run Installer and select this new volume as target volume (source being your boot volume). And install.
  3. Shutdown Haiku
  4. In VMWare, switch the boot disk to now be the just-installed. You can even remove the initial one from the VM config.
  5. Reboot your VM
  6. Your newly installed Haiku partition should boot fine

Regarding WebPositive, yes, it has libraries dependency that can’t be honored with an old Haiku revision like R1/alpha2, and will only works with a recent revision.

Thanks, phoudoin! Worked like a charm!

You’re welcome… in Haiku early users community