WebPositive crashes on recent nightly

Hello everybody.
I downloaded hrev46629 today and when tried to launch Web+, it crashes.
Apparently, it is because of a segment violation.
Anyone else experiencing these crashes?
BTW, I’m on Virtualbox (the most recent version).
Unfortunately, I am not able to open a ticket for this atm.

Since it’s a seemingly random segmentation violation it may be related to this ticket: https://dev.haiku-os.org/ticket/10279

I’ve been anxiously waiting for that ticket to get fixed, but it’s been xmas so I guess development slowed a bit (don’t want to put too much pressure on the devs either).

I’m using a nightly from last week, and have seen crashes from webpositive but not at startup. I think it may be the more general problem above, so probably the best thing to do is keep an eye on that ticket and update when it’s fixed. You could run an older nightly until then.

Also, might be worth adding a debug report to that nightly, or at least mentioning the fault to them and see if they want a report.

Just tried 46632 and Web+ starts up fine. Also using Virtualbox.


Thank you both for your help and feedback.
I figured something must be wrong with my installation (Virtuabox) because I later tested on real hardware and did not have these issues.

– louisdem