VMWare Player Mouse Acceleration Settings

Warning: This post contains subjective information…

OK, I can´t seem to get the mouse to move in a way that feels comfortable.

When I move the mouse quickly and then stop, it seems to way overshoot its intended destination. However, if I go to the mouse preferences and move it down by one notch, the same action will result in a massive undershoot of the target.

It´s difficult to quantify this problem as it could be just my interpretation.

I´m using VMWare Player 12 on Slackware 14.1 (Xfce) with a Razor Abyssus gaming mouse set to 1800 dpi. When running Windows 7 under VMware, or just using Linux, the mouse seems to respond in a fairly similar way, but Haiku feels quite uncomfortable.

Is this something to do with the acceleration curve? Maybe a combination of the curve coming through VMware from the host OS and Haiku´s own acceleration on top…

I haven´t tried physical hardware recently but I don´t think the problem was quite as pronounced.

Thanks Adrien, I wasn´t aware that this was an option. I can´t find any option in VMWare to change this - but it´s nice to know that Haiku is working as it should be, anyway.


In most virtual machines you can set the mouse pointer to "absolute" or "tablet" mode, or use add-ons that enable integration with the host cursor. In these cases, only the host will handle the mouse acceleration, which will solve your problem.