VM Ware Fusion - No sound

The Nightly builds seem to run fine in VMWare on an iMac 5K, but I get no sound, and no recognized sound card in the media preferences. Has anyone tried HaikuOS on a 5K? Checking the “About this Mac” features lists Intel High Def. Audio, AuDIO ID: 122. Thanks!

I had a go at writing an es1371 driver for Haiku but I ran out of time and patience. If I were a little younger, maybe I’d have stuck at it.

No, this is related to the recent changes to the Media Kit (or possibly launch_daemon). I don’t have any sound in VirtualBox either…

VMware Fusion emulates Creative AudioPCI 97 (ES1371) which requires the use of opensound driver.
Sound works fine here in VBox.

Got it, and yes - Open Sound did restore the audio in VMWare 7.1.2. with HaikuOS 49431. Thanks !

It says “Could not find the mixer”. In Media Prefs under Audio settings the Audio Input, Audio Output, & Channel say “none” I’ve tried changing VMWare’s Audio settings from “System Default” to “Built-in Output”, but that makes no difference. I have W2K installed, and the sound in that works fine through VMWare. TIA

Try install OpenSound drivers - it’s buggy, but it works:
http://haikuware.ru/files/misc/opensound-4.2-1-x86_gcc2.hpkg

When you open the volume control desklet in Deskbar, does it say “No mixer” somwhere, or not?

Also available in the Depot :slight_smile: