VLC stopped working

tried to play an mp4 file that used to play with vlc, but it crashed. Anyone has the same problem? I don’t know when this started (I am using nightly build long time ago).
The report starts saying:

Debug information for team /boot/system/apps/VLC/VLC (1292):
CPU(s): 2x Intel Core 2
Memory: 3.86 GiB total, 755.00 MiB used
Haiku revision: hrev56814 Mar 10 2023 07:02:19 (x86_64)

Active Threads:
thread 1292: VLC (main)
thread 1293: pthread func
thread 1294: pthread func
thread 1296: pthread func
thread 1297: team 1292 debug task
thread 1303: BApplication_thread
thread 1304: pthread func
thread 1305: pthread func
thread 1311: QSystemTrayIconLooper
thread 1313: w>VLC media player
thread 1295: pthread func
state: Exception (General protection fault)

you can try MPlayer and media player.
if also crash like this, maybe it’s the problem of the video.
if work well in the other system, haiku bug.
if work well but VLC, the problem of the VLC.

On R1B4 32bit hrev56578+70 VLC is stable – except notification icon.

If you are on nightly build you may experience crashes more frequently than otherwise.

I would suggest to go back to the stable release if not necessary to be on a bleeding edge version for some function you find only in nightly build(s).

I just got a KDL recenly due to some NTFS stuff since weeks … I downloaded a 3.1 GiB size file that does not fit onto small BFS filesystem I had on USB install thumbdrive - so I chosen the attached NTFS USB HDD’s root dir to download - it almost finished in Web (Epiphany) browser (2.86 GiB) when this recent crash happened. I left the machine for human needs and when I came back after half an hour I faced with KDL message / prompt and frozen Haiku -

It was unexpected as I had not experienced crash for a long time … I forgot Haiku is in beta stage :wink:
I was so cherished meanwhile … I had to get a wake up hit - seems :smiley:
No day-dreaming, hombre …

Have you reported this KDL?

Not yet.

But i will soon, if no solution is found.

I also encountered the same problem.
However, I later used to search for VLC files, and deleted everything that could be deleted. Download and install VLC again.
VLC is ready to use.
Only once, restarting VLC didn’t work again.
Just wait until VLC is updated.

(use google translate)

1 Like

VLC work fine
Beta4 +70
64 bit

1 Like

Hello @ryk,

Had you tried what Ilovehotdog offered above ?
I think it worth a try … you can assure about your Haiku install and/or your hardware is healthy as well !..

When my Dell Inspiron 9100 started to give unexpected errors first I thought Haiku is the source of problem ,as it was nightly, but unfortunately it was HW issue as it was getting worse/more serious it was not stable even during BIOS setup.