VLC player!

Hi, I was looking at youtube ( I was using Linux ) and came across a haiku demo and was surprised to see several versions of VLC player on the screen at the same time. I was amazed because I had tried VLC on my Alpha install and got nowhere. The version playing on the youtube was obviously pre Alpha but I would have thought if it played pre alpha then it would play on the alpha?
I know ( think is probably closer to the truth ), that my Nvidia driver isn’t loaded because the screen scrolling on some sites isn’t smooth.( not to be construde as a moan ). I have looked to see what drivers are installed but was unsuccessful.
Another question if I may, Bon Echo doesn’t use Xmarks( old foxmarks ) does anyone know of a way to copy Firefox (W2k) bookmarks over to Haiku Bon Echo.( When I look at the W2k NTFS partition read/write Haiku refuses to work, I even tried emailing them but that didn’t work either)
Any help as always appreciated.

VLC works here with no trouble. Did you get it from http://haiku-files.org/files/optional-packages/ ?

Hi dened!

When it comes to playing video, it all depends on what kind of codec was used to create them. XVID, for example, works rather well with VLC. A good way to find out details of a video file is to open it with MediaConverter, though you can’t re-encode with it yet.
For me, playing video files is very much a hit and miss. Some work, some don’t, some only video, some only audio… If you have small samples of non-working videos, or find a (legal!) URL where to download them, consider creating a ticket in the bugtracker. I bet David McPaul, the local codec guru, would like to take a look some time.

You can check if a graphics driver is loaded with “listimage | grep accelerant” in Terminal. Here it returns

~> listimage | grep accelerant
722               /boot/system/add-ons/accelerants/nvidia.accelerant 0x82f000 0x865000    0          0
TEAM 2561 (/bin/grep accelerant):

I don’t know about “foxmarks”. I used a standard Firefox 3.something under Ubuntu and could simply use its “bookmarks.html”. Maybe you can open the “Manage Bookmarks” panel in W2K and export the bookmarks to some other format?


This just in from Michel Clasquin-Johnson on the mailing list:


Hi Michel, Thankyou for your reply. I clicked on the link but nothing is working there. I clicked on the Foxmarks download button which takes me to Xmarks. I then clicked on My Foxmarks which allows me to log into my account, but from thereon nothing.
Added: I played around inside my Foxmark account and clicked on Tools and then exported to html and save to my Desktop. Works great.
Again, thankyou.

Hi Humdinger, Thanks for that. The nvidia driver is loaded.

Hi bbjimmy, Yes, thats where I got it from. Vlc player is visible but doesn’t play. I tried running a DVD through it but it wouldn’t work. I will keep trying. Thankyou for your reply.
Added: It does work. I have just realised that I am not thinking and assuming it will work ala Linux/Windows. I inserted a music cd which took about 50 seconds to work.
I have never used an Alpha version of any software.
Thanks again.