VirtualBox + VMSVGA driver (vmware). Need test

I changed vmware video driver a little bit. Now it can be used with VirtualBox (VMSVGA).

  1. Change the VirtualBox video adapter settings to VMSVGA.
  2. Set video memory size to 32M or 64M for HiRes.



You can install driver vmware_video from my repo
pkgman add-repo


Working happily at 1080p on Beta 2 on VMWare Workstation. Thanks!

So far so good on VirtualBox with Beta 2.

On the nightlies, the display resolution cannot be set higher than 1400 x 1050. Attempting to set a higher resolution results in a general system error. This occurs with VirtualBox 6.1.18 r142142.

Same here, did a fresh x86_64 install in VirtualBox (same version as @win8linux), anything higher then 1280x1024 results in a message general system error (native resolution on the host is 1900x600 (not available in the list))

What version of Haiku are you using? Did you try vmware video driver from my repo?

What size of video memory setting for Haiku VM? My setting is 64M.

Below you can see Haiku with resolution 3440x1440 in VirtualBox (linux).



That did the trick here, thanks! :slight_smile:

Same here, it also worked for me. Thanks!

Can you share the source code so we could patch the original driver?


Yes of course, already. I sent Pull Request in the morning.

I also added screen size 1600x900, but did’t make pull request for it. You can get full source with my fixes in my github.


Could you add one for 3072x1920? See Increase maximum screen resolution on Haiku on VMware Fusion for Mac

1 Like

Yes. You can try it in my last build (1.2.4).


Message probably should be changed to less confusing “out of video memory”.


Best would be not to offer those resolutions in the first place, though :slight_smile:

1 Like

Is there a way to display such a message from the accelerant ? I know only how to write to console.

You right if it is driver for real video card. User must see list of supported size only. We can not change video ram on modern hardware.
In our case, the user will be better to see that it can set a big screen size.

You need to return error like B_NO_MEMORY instead of B_ERROR.

OK. It is better than just a message about a system error.
Added to driver build in HAKILO repo.