Usb3 card support


Some time ago, I had a problem with my usb connectors on my motherboard, and they’re not working anymore.

I’ve installed an USB3 pci card, and it’s working fine on Linux, BSD…

I tried today the latest Haiku nightly build, and I don’t have access to my external disk or usb key.

It is this model (found with lspci on Linux):

02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)

Do you think there is a way to make it work on Haiku?

There is a work in progress xHCI bus driver, it is not in the image yet, though.
You could try to add it yourself and see if it works.

I read about the Google Summer of Code project to port USB3, but I thought it was already re-integrated. I don’t think I’d be able to build it myself, but maybe it’s in the new release. I’ll look at this in the future anyway.


from the link above it seems new code was added about this issue. I’m running at the moment revision a5d9833 I’ve downloaded recently. Usb3 still doesn’t work, but is there a way to load a module in haiku? (like modprobe on linux)

I see there is this file here:

but from its content it doesn’t seem to be related to usb3.

There are files related to uhci ehci and ohci. It seems usb3 is only “xhci” :

XHCI isn’t ready yet, that’s the reason it is not activated in releases at the moment.