Updating Haiku

Hello. Since one month ago, I don’t get any new update from Haiku repo. I’m stuck with hrev53552 (x86_gcc2) from october 19.

I’m pointing to:
in the Repo settings.

There is some issue with the nightly builds?

Thank you!

I have just updated one of my machines, and the new version is 53561. Another machine has been on that for a couple of weeks, I think.

Are you using 64 bit version?

I originally typed the word YES, but am obliged to type more words because a one-word answer is apparently not acceptable on this forum.

Lest you are in any doubt, YES, I have a 64 bit computer and use 64 bit software.

Thats because the forum a limited minimum cpunt of letters to post. This helps a bit reduce spaming

I have the same issue. I hope this gets resolved soon.

https://eu.hpkg.haiku-os.org/haiku/master/x86_gcc2/current is correct for the 32-bit builds (and working as expected, ignore the initial “not found” page, that’s the correct repo). You can test it via: https://eu.hpkg.haiku-os.org/haiku/master/x86_gcc2/current/repo

I heard some rumbling of some recent package kit changes causing issues though… not sure what’s going on there. See https://review.haiku-os.org/c/haiku/+/1963

As an alternate you can try the new fancy repositories which are built with Concourse. They use a new redirector thinggy I wrote in Rust to serve packages / repos from a remote s3 bucket:

pkgman add-repo https://test.hpkg.haiku-os.org/master/x86_gcc2/current

Keep in mind that test repo may change in the future (or go away))

Can we somehow make this more user friendly? Like, show a page explaining how to add the repo or something there? (well, kind of not really important if we switch to the concourse-based ones someday)

Simple Index.html with logo of Haiku and the terminal command to add

The new redirector dumps it’s knowledge at each level which is a bit more friendly:

The plan is to make its output a bit more friendly as well (Simple HTML page describing what you’re seeing)


@kallisti5: Hello! and thanks for the info about the new repos. I tried pointing to the “Test” url that you provided, and yes, I get the following updates:

    The following changes will be made:
  in system:
  upgrade package haiku-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package haiku_x86-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package webpositive_x86-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package makefile_engine-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package haiku_loader-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package haiku_devel-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku
  upgrade package haiku_x86_devel-r1~beta1_hrev53552-1 to r1~beta1_hrev53581-1 from repository Haiku

However, if I get back to the original repo url, I don’t get any updates from it.

Still not working here (not even with adding the test repo), stuck at hrev53552 …

I had the same problem (on x86_64 though) and ran ‘pkgman full-sync’ and got a new hrev. All good now and updated to the latest version :slight_smile:

Using the default eu.hpkg.haiku-os.org repo.

1 Like

ah yeah. full-sync is required sometimes (generally when a bunch of dependencies change all at once) We need to start collecting information on what exactly goes wrong when systems enter this situation.

1 Like

Today it worked! :sunny:

Fixed here too! Today I updated to 53592, using the default repo.

Thanks for your help! :+1:

when will beta 2 be released?

1 Like

Had the same problem for some time now in 64-bit Haiku. pkgman full-sync resolved it! Thanks a lot :slight_smile:

Beta 2 will be released when it’s ready. We have a new release of WebKit to push out (which was delayed because I had no time and I’m the only person working on it, and because of problems with the new memory allocator, which I removed for now), and we have some polishing to do on HaikuDepot as well.

thing is it was stated there would be a new beta last month, that came and went. but i get it.