Update available only through terminal

I’ve just installed the latest release of Haiku.
And I cannot use SoftwareUpdateer/HaikuDepot. Any attempt to update or even install and app results in error. However, Terminal/pkgman works, at least for updates.


^Just an example of the errors.


Are you running a beta3 install? If so, those errors are kinda expected right now, as the process to switch to beta4 has already started.

You may want to switch your install to beta4:

pkgman drop-repo Haiku
pkgman add https://eu.hpkg.haiku-os.org/haiku/r1beta4/$(getarch)/current
pkgman full-sync

That should update your system to beta4, and after that, the errors you’re seeing should go away.


Great, trying this now!

Don’t forget to reboot after that big update! Good luck!


Is that the recommended solution for users atm.? Beta 4 is not released yet…

No, but the beta4 branch is feature-frozen and will see only bug-fixes at this point, so there’s not really much reason not to upgrade. In fact I think RC0 will be generated soon…


Thanks for clarifying @waddlesplash :+1:

Ok, I’ve updated :slight_smile:
WebPositive has died and as, unexpectedly, any other Haiku browser is considered “too old” for this HAIKU website (lolwhat??) I have now to use another PC to write this :slight_smile:
In fact, now I can install much more apps. But, for example, LibreOffice is still unavailable to me.

So, any option for web browsing that would allow to use Haiku webpages? I am afraid to even mention youtube…

MiniBrowser can do youtube, and all pages I have thrown at it… I think that came from package Epiphany (I have all the web browsers installed, so not 100% sure)… It uses load of RAM though, easily 2GB… And it doesnt remember google login, so every time you start it, its forgotten any info, passwords etc. QMPlay2 is useful for Youtube too. Its quite quirky to get used to, but it works great (and no YT ads as a bonus) It also supports internet radio, so quite a versatile program for media

1 Like

Minibrowser came from WebKit_GTK. Epiphany has it as a dependency.

1 Like

None of these works :slight_smile:
Minibrowser/WebKit_GTK cannot start, QMPlay2 misses files (pyton3?) if trying to launch any youtube video.

Minibrowser is the webkit test browser. It’s not directly ment to be used as a full web browser but rather just a test of webkit.
Seems user-unfriendly to install this with the webkitgtk package :g

^As I said, it won’t even start.

I ran into a similar issue where I just installed a nightly build, and after updating, I didn’t reboot and just installed epipahny before restarting. Upon reboot, Epiphany and Minibrowser wouldn’t start.

I wanted to take a look and see what was causing it not to start, and I noticed that the glib-2.0 folder which has schemas was missing from /boot/system/non-packaged/data

I made the folder glib-2.0 in the above location, than I copied the schema folder from /boot/system/data/glib-2.0/schemas to /boot/system/non-packaged/data/glib-2.0/schemas.

After copying I than ran the following command:

glib-compile-schemas /boot/system/non-packaged/data/glib-2.0/schemas

This creates a file named gschemas.compiled. After that file was created rebooted the machine and both Epiphany and MiniBbrowser were working.


I just installed Web on my R1Beta4 setup, and it crashed when run. I already had the glib-2.0 folder in the right place, and running that command fixed it for me. Thanks!

This seems to be something that should be reported at Haikuport’s Issues (something like for this one, for example).

I have changed the version to 64-bit. Now WebPositive works again, AND I was also able to install and run LibreOffice!

However, the left button of my touchpad doesn’t. Damn! :smiley:

Also, I’ve created the filegschemas.compiled, but MiniBrowser still won’t start

Thy this:

rm -rf /boot/system/non-packaged/data/mime
rm -rf /boot/home/config/non-packaged/data/mime
gdk-pixbuf-query-loaders >/boot/system/settings/gdk-pixbuf-2.0/loaders.cache

It worked! Amazing, youtube on my 2008 laptop! :smiley: It runs almost normally :)) (the thing is - this laptop accepts ONLY Windows XP SP1, and, as I found out, both 32 and 64 bits Haiku).

Now the only problem that is lef is my touchpad. It worked perfectly fine in 32 bits, it seems 64 bits driver version is not quite there for it.