Unsupported vesa mode for trident cyberblade i1

I own an old compaq evo n110 . The gfx card is a trident cyberblade i1. The Haiku boot process is blocked because of it and even the safe mode isn’t able to force. I tried to install BeOS Pro 5. It worked but in black and white. I looked at bebits and found a vesa patch that worked. From the BeOS partition I dd on a separte partition an Haiku iso image following a posted article on booting. I used makebootable. I tried to copy the trident driver at /system/add-ons/kernel/driver/bin but Haiku still don’t want to boot.

I know this is certainly not à focused target machine, but it is for now the only Intel Pc I have. I ported a few time ago the gnuplot software. I want to coninue but it won’t be possible easily if I do not succeed to install Haiku on this old compaq.

Can you help me or make the next release able to boot with a trident cyberblade i1?

Thanks for considering my request.

PS: even on that old machine BeOS rocks surprisingly fast! I hope that Haiku Would be also that efficient.

Did you create a link to the trident driver in /system/add-ons/kernel/drivers/dev/graphics ?
Sounds similar to this issue: http://dev.haiku-os.org/ticket/2337

First thanks for helping me.

I yes did make a symlink in /system/add-ons/kernel/drivers/dev/graphics, but it doesn’t work either.
Pressing the shift key at boot time, I noticed the following info using the “Display current boot loader log” option:

VESA version = 1.2, capabilities 0
VESA support to old.

… (continue booting)

vesa: vesa_init() completed successfully!
vesa: acc: vesa.accelerant
vesa: vesa_uninit()

Up to that point everything is blocked.

I thought that using the patched version of the trident driver for BeOS 5 Pro would work. I wonder if the functions inside the driver are the same for BeOS and Haiku ? If not, this certainly explain why it doesn’t answer my problem.

Does such a VESA v1.2 driver exists for Haiku ?


A “vesa patch” for BeOS that allowed it to boot in color instead of black and white (default grayscale VGA mode when no available drivers are detected) was not a patch to the trident driver, it was a patch to allow BeOS to boot to a specific vesa mode instead.

That likely means the BeOS trident driver didn’t support your chip either, and Haiku’s vesa driver doesn’t support a lot of older chips (Intel i810 for example) that BeOS’ driver may have.

Trident chips were notorious for being terrible, so it doesn’t surprise me that it’s not working.

I’ve got a stack of old Trident cards here that I should eventually try in Haiku, but I’m relatively certain none of them are likely to work properly.

Well, I used “patch”, because it was named so in Bebits repository : “Trident driver patch” (http://www.bebits.com/app/3004) - and it worked well for me.

My problem is today that I would like to boot Haiku on this old machine and not BeOS Pro 5. I would like to continue my humble port of gnuplot and then octave (if we get the full fortran environment support in gcc 4).

I have also tested some linux distro on this machine (Ubuntu, Fedora) and they all successfully boot and run. So isn’t there some common sources that a nice developer may include in Haiku booting process ?


Actually ftp://ftp.beos.hu/pub/beos/mirrors/bebits.com/Drivers/Graphic/patchtrd.zip seems to be a patch for the trident driver.

Anyway, could you try to replace vesa.accelerant from this archive https://dl.dropbox.com/u/15787359/vesa_patched_hrev44265.zip

In short: Nope.

Haiku’s video drivers are different than other OSes - it takes someone with knowledge of writing a Haiku video driver, the hardware itself, and motivation.

Edit: BTW, you should create an enhancement ticket if there isn’t one already.

Unfortunately it doesn’t not work. I’ve dropped the file vesa.accelerant at the right place but it stops at the same point (see description above) Damned VESA 1.2! … hum … Well, I would also appreciate that someone explains (“for beginners”) how all those files are used during the boot process. How does this function and who calls who… just to increase my knowledge.
Also, there are numerous of driver and accelerant files in each respective folders. How does the bootloader choose the adequate one?
Don’t know how to proceed now for booting my partition 1 Haiku… so don’t hesitate to keep on helping me. Appreciate.

The bootloader doesn’t choose a video driver at all - it uses VESA mode only for the splashscreen. Once the kernel is loaded, it is responsible for loading all the video drivers and allowing each of them to find suitable hardware. If no suitable hardware is found, each driver then unloads. The “vesa” driver always remains loaded.

Once the app_server is loaded (which is done via the bootscript), it loads the appropriate accelerants (userland-side of the driver), which then search to see if their accompanying drivers are loaded. If no accelerants are found to be available for loaded drivers, the vesa.accelerant is used as the fallback mechanism.

It’s generally assumed that any hardware not supported by a native driver is supported by the vesa driver/accelerant, but that isn’t true for older chips that don’t otherwise follow modern VESA guidelines. This is why you are stuck in the situation you are in it.

There is at least one driver in Haiku that isn’t supported by our VESA driver, and therefore it won’t show a proper bootscreen, but it will show a desktop once the app_server is loaded - that is the Intel i810 driver. Other drivers can be written for Haiku even without functioning VESA, but as mentioned before, it requires developer with know-how, hardware, and motivation (and probably specs or a reference driver to work from).

Thanks for the explanations. They are very clear.

As you said it, I’m just stuck where I am. Well, I still have a functioning BeOS Pro 5 partition on this machine… not that bad. Big issue with this old OS is beeing able to be connected to the internet with a D-Link DWA-131 USB key… hum …