Uninstall boot manager - button greyed out


unfortunately, Haiku does not work well with my hardware,and I want to restore the original boot manager (when only Windows was booting up)
But when I start the installer in Haiku, click on Tools to start boot manager, the button “Uninstall” is greyed out.
I also tried to do that with the boot USB that I used to intall Haiku in the first place – same problem.

The boot usb still has an “MBR” file in ~/config/settings/bootman/
(but not the desktop installation of Haiku).

What could I do?

Known issue, as you already found out. Even if that gets fixed, won’t help your case so…

You’ll need to use /bin/dd to write back the data on that MBR backup file.

dd if=/boot/home/config/settings/bootman/MBR of=/dev/disk/[...]/raw

You’ll need to adjust both the if= parameter (to point th the MBR you got on the USB drive), and the of= one to point to your particular HDD/SSD drive (as an example… in my case, that would be: /dev/disk/scsi/0/0/0/raw.

Please double check the parameters to dd, specially the of= one before you hit enter.

If that fails, /bin/writembr should write boot code good enough to boot the active partition on the given device (you can call it without parameters, it will ask you to confirm installation on the HDD it finds).

If even that fails, you can re-install BootManager, only add your Windows install, and configure it to auto-select that option with minimal/no delay.

Note: the MBR backup file ended up in the USB media, because that was what you were using at the time of installing BootManager. One could argue that that file should be copied to the final install partition (with a distinctive name enough, as to not clash with further backup files BootManager (from the final install) might create.


Thank you very much BiPolar for such detailed solution.
I followed the first one and it worked.
However, at first restart it booted me back into Haiku - that’s because, in my troubleshooting attempts, I had marked Haiku partition as “Active” in Drive Setup (found in Applications). So I went back there and marked instead the first windows partition (mine called “system reserve”, ~50MB on win 10) as Active. Now it boots into Windows as usual.

I’m sure your steps can help others too.

I totally agree with your last suggestion. At first, I freaked out when did not find the MBR file on the supposed location (then realized could be on usb).

best regards


I think the current choice is safer as your target disk might become inaccessible for whatever reason.