Unable to ping in local subnet using ipv6

Hi, I am trying to use the ping for pinging an ipv6 link local address.
I have setup an internal network in Oracle virtual box . In this network , I have a linux VM and haiku VM .
The linux VM network details are in the following picture

I have manually configured ipv6 settings in Haiku as follows

When I am trying to ping the linux vm on the enp0s8 link local address from haiku VM , it is failing

The output I am getting

Can anyone kindly suggest where I am going wrong ?

Thanks.

1 Like

I know nothing about it but, addresses consist of 6 groups of 4 digits separated by semicolon, right?
Then, is it normal that your netmask has 8 groups?

I know I used “bridged network” in VirtualBox back then when I used it, maybe you could give it a try?

I Tried the following settings, still it is failing


Output

I am unable to ping in bridged network also.
When I am trying to ping , tcpdump is not showing any outgoing packets also.
Command used
tcpdump -npi /dev/net/pcnet/0 icmp6
Getting the following output
sendmsg: Network Host Unreachable .

@cmeerw @waddlesplash Any idea on this ping for ipv6 ?
Also, given there have been some changes to ping code recently, which haiku version should I be using if I want to access the old ping ?

Haven’t used VBox for a long time now, could check VMWare Player when I got that booted (doesn’t happen much anymore). Tried in Qemu, that didn’t work there, but also uses different IP so was to be expected.

pcnet is known to make problems:

1 Like

ipv4 ping is working perfectly.
I am facing issue with ipv6 .
Also, I tried making the changes discussed in the link but issue persists.

You might check the route table.

No, it’s 8 groups of 16 bits: https://en.wikipedia.org/wiki/IPv6

In Link-local address communication , why should I need a routing table ?

Posting the routing table

1 Like

Only the loop is declared by default.

I tried adding route for the pcnet interface but that is rejected , as is shown in the picture . @korli