Unable to burn the latest nightly to a USB drive


#1

I have just tried to burn a recent ‘anyboot’ nightly to a USB but while the files appear to have transferred OK the OS doesn’t boot…the PC is set up to boot first to any USB drive.

I’ve tried to find reference to the solution in the forum but nothing solves the problem. Do I need to set a boot file…?


#2

OK Got that sorted…bumbled my way thru!


#3

First you does not can burn a usb stick ;-).
Second you need a usb stick or drive with boot function.


#4

?

I’m not aware of any USB drives where it is not possible to boot from. Unless they don’t use the standard USB mass storage protocol, but I’ve only ever seen one such device, and that was in the late 1990s. Do they still exist?


#5

Hey, I’m fixed up OK! Thanks for your comments :wink:


#6

I haven’t seen it myself. But one used to read every once in a while of people keep failing to dd a bootable USB stick, until they used another stick. Then the same dd would work…
Maybe some GPT whatever remnant on the other stick? Dunno…


#7

I does not get any usb stick running with haiku, so i think they are not able to boot from.


#8

As the OP I have to say that when I did it properly it works perfectly…the instructions are a bit vague but are accurate…my USB runs just fine and boots on 2 Laptops!

…be sure to unzip the zip file first!


#9

Well, yes, unzipping the file would help if it’s compressed.

I use Etcher from either Linux or Windows to flash a new USB if I manage to screw something up on my hard drive install. If you really want to, it’ll boot, let you partition the USB itself, and then install to the new partition and switch that to the boot partition. Over and over.

It’s worked just fine for me on both a crappy old 16 Gig Staples brand drive I scooped up years ago when I first tried Linux, and a brand new 256 Gig SanDisk Ultra, so I’m not sure where one would find a USB these days that can’t be used as a bootable drive. More than likely the USB port just doesn’t have preference over the hard drive in the BIOS boot settings.