Unable to boot USB hrev50321-x86_gcc2_hybrid-anyboot on 2 of 3 PCs

I’ve tried to prepare a USB stick with haiku-nightly-hrev50321-x86_gcc2_hybrid-anyboot, following the instructions for Linux via a terminal:


System 1 is a Gigabyte GA-6OMM7E motherboard, has Plop built in to the BIOS, see https://www.plop.at/en/bootmanagers.html
Note! This system has booted Haiku USB before, as with for example revision 47380, so neither the boot manager nor the hardware is believed faulty

System 2 and 3 both boot USB via the usual BIOS boot device selection, nothing unusual there:

System 2: Fujitsu Siemens Amilo PA 1510 - fails, says “Failed to load OS, press any key to reboot” with USB plugged in

System 3: White box PC with Athlon XP based motherboard Biostar M7NCD, only one that booted

Any ideas? Yes, I’m retrying with the current nightly. :slight_smile:
Oh and yes, the SHA256 sums posted in the download area match, so no corupt files here

1 Like

You don’t give much details as to what went wrong in system 1. Is it the same error as system 2? Is it different?

Sorry, no.

The errors on plop are worded a bit different than in a BIOS.

“Boot Error”
“No boot device found, please retry it” (again in all cases where it doesn’t work, the USB drive is plugged in to a USB port that has been used before, mounts ok inside the OS, etc.)

I’ve just retried with revision 50332. Still no luck.

1 Like

hrev51090-x86_gcc2_hybrid_anyboot has the same problem on usb stick and on DVD takes about 30min to boot and install will fail with “device calibration error”.
I went back and got hrev51074_x86_gcc2_hybrif_anyboot and It is ok.