Unable to boot Haiku from GRUB2

I installed Haiku on my computer that’s dual boot with Windows 8.1 and Ubuntu.
And I tried to add the Haiku on GRUB2 menu following the installation guide. (Installation Guide | Haiku Project)
Actually it is listed on GRUB menu but when I chose the “Haiku” the error message

error: invalid EFI file path.
Press ane key to continue…

shows on the display. Also I checked the this discussion, but I cannot fix it.

Here’s what I’ve tried.

On Haiku
After install Haiku from stick memory, type “makebootable /Haiku” on Terminal.

On Ubuntu
Add the text on /etc/grub.d/40_custom like:

# Haiku on /dev/sda7
menuentry "Haiku" {
	set root=(hd0,7)
	chainloader +1

And put the “gpt” is also tried.

	set root=(hd0,gpt7)

Screenshot from 2021-07-04 14-42-34

Sorry for my a little of knowledge about Haiku and computers.

Welcome Aero!

I never used an UEFI system, so I can’t be of much actual help, but have you checked:

It looks like what you’d have to add to the grub config is something like the there mentioned:

# for EFI systems
menuentry "Haiku" {
	insmod part_msdos
	insmod chain
	search --fs-uuid --set=root <EFIBOOT partition UUID>
	chainloader ($root)/EFI/BOOT/BOOTX64.EFI

And don’t forget to do the sudo update-grub at the end.


Hi Aero,

Did you copy the EFI bootloader from your installation medium to your EFI partition?

UEFI boot


Thanks for the reply.
I’m sure the link is very helpfull for me. But it seems that there may be a problem with the EFI Bootloader. I’ll fix it and then try your suggestion.

Thank you for the reply!
I haven’t done the steps in the link you provided.
If you don’t mind, could I few questions for you?

  1. It say “partition at the start of the disk”, but there is a Windows Recovery, is it a possible adding EFIBOOT to the before Haiku BeFS partiton?
  2. I created a 32 MiB partition, but “EFBOOT” is in lower case. Also, when I mount it and open it, there is a “RECYCLED” folder that I cannot delete. Is there something wrong with my procedure?
    I apologize for this very rudimentary question…
  1. I don’t think it’s the problem, but maybe a Haiku team can answer this
  2. The label of the partition has no impact. Mine is “efi”. I also have the “recycled”, nothing to do with it. Just copy the bootloader from your installation medium with same subfolders scheme (and the same that you have set on grub config).
1 Like

Many thanks for you!
Now I can start up Haiku from GRUB2. I write this message on Haiku!
I’m going to learn more about Haiku.
Thanks again for your help!


Welcome to the community, I hope you’ll enjoy this OS as much as me :wink:

1 Like

After setting up the correct settings for EFI boot, I followed the link you provided and edited the GRUB settings, then it booted successfully!
Thank you for your helpful support!

Great you could make things work! Hope it’s smooth sailing from here on… :slight_smile:

1 Like