Unable to boot from USB

Hi, thanks for this great project!

I’d like to install Haiku on an Intel-based iMac from 2019, but I can’t get the USB drive to boot. I tried the haiku-r1beta4-x86_64-anyboot.iso, as well as a recent nightly (hrev57736-x86_64) and dd’ed directly to USB, but when I select from the Mac bootmenu (I get two options for some reason), I only get a blank screen and a reboot after a couple of minutes.

Any ideas what other avenues I could take or how I could get any logs? I tried to dd the anyboot iso to an external ssd (same result) and messed around with EFI and refind but honestly not sure what I am doing.
Any tips would be appreciated!

1 Like

You can try booting refind and with it booting the haiku loader, but from your post it seems you already tried that.

You can try mashing space after selecting the option, ideally it should give you the bootloader options menu and you can try if for example the onscreen log helps you.

1 Like

I had inconsistent results with dd so I would recommend flashing the anyboot image with Balena Etcher.