Unable to boot from hard drive

I have installed haiku to my hd. I am able to boot haiku using the livecd and choosing the failsafe graphics option. I have added haiku to my current bootloader with the chainloder +1 option. I can boot haiku with, the splash screen comes up, the icons light up, screen goes black and seems to freeze.

I am sure it is due to the intel graphic card. I have a opti-plex gx-280 p4 3.0 GHZ.

I tried to change the screen settings but that did not work, It froze the machine with the debugging window dropping down. I did not write down what it said. I will try to do it again when I get a chance,

I have been tring to search for a fix but did not find much help. Any help would be greatly appreciated.


If video issue (safe mode options):

  1. choose to use fail-safe video option

  2. select fail-safe video mode ( ie: 1024x768x32 )

  3. tells Haiku to use VESA driver, 2) selects the video mode

If hard drive issue:

  1. if sata, try setting in BIOS to legacy mode
  2. Haiku safe mode options, disable DMA

Those are likely reasons why Haiku won’t boot for you. For drive issue, turning off DMA works some of the time.

Yes, the gx280 uses integrated i915 video, and Haiku’s intel_extreme does fail on it. I used to have one of these machines at work :slight_smile:

I am able to start haiku but only using the livecd.

If i boot haiku from grub. The splash screen comes up, the screen goes black and freezes.

It is a bit inconvenient to have to use the livecd to boot my hard drive installation.

My question is how do I force haiku to start with the vesa drivers instead of the intel drivers,

Sorry if I was clear enough.

Thanks Kelean.

rename /boot/system/add-ons/kernel/drivers/bin/intel_extreme and the system will default to vesa mode.

I tried to rename what you suggested.

When I boot haiku from grub I get a panic fault.

PANIC: Double Fault!
Welcome to Kernel Debuggind land…
thread 70 “piccsswo” running on CPU 0

The system goes into a hard freeze.