Unable to boot Beta4 from bare metal


I’ve installed Haiku before several times, but this time cannot boot from the newly installed partition.
The system is a AMD Athlon 300GE cpu on a MSI B450M-A PRO MAX motherboard with firmware update. This means that only UEFI systems can boot.

The target disk is exclusively for Haiku. The partition type for the whole disk is shown as ‘GUID Partition Map’.

I’ve already read the instructions (although it says for Beta3) and created an EFIBOOT partition as described. Tried to create it once at the beginning of the disk, another time at the end of the disk. Same result.
This seems to be working fine, as when choosing the medium to boot from there’s the Haiku option.
The problem is that it can’t find the Haiku volume and asks to re-scan, but to no avail.
If I place the USB stick, the SSD Uefi partition boot the Haiku partition from the stick.

The Haiku partition is at 112GB, Volume Name ‘Haiku’, formatted with the ‘Be File System’. The parameters set are ‘MIMEs, Attributes, Queries’.
It doesn’t show Active or Boot.
When I click with the right button mouse over the SSD Haiku partition and choose ‘Change parameters’ there’s no available option to set the partition as ‘Active’, ‘Boot’ or anything else. The only thing available is the Partition Name and Type.

This table summarizes the differences:

What should I do?

Not sure if it will help you, but I had a couple of installs that didn’t boot, & when re initializing the disk, chose Intel, (which I presumed to be equal to MBR), partitioned as one partition, & set it ‘active’ (box lower left of dialog box); this then booted up OK.

Edit: My thought here is that the ‘active’ flag may need to be set after initializing the disk, which I don’t think I did the first time, (I’m new to Haiku, so could well be wrong). :wink:

Thanks @camtaf, good idea, but that didn’t work.
I even have two motherboards of the same model, one where the firmware was updated and another one where it wasn’t, but cannot still boot Haiku either with a GPT or MBR partition types.

I guess I have to sell this combo motherboard and cpu.

Normally, these flags are only needed with Intel partition scheme and MBR booting.
MBR and GPT partition scheme are using the same place on the disk, so you can’t mix.
If you are using GPT scheme, you have to use UEFI.
If you’re using Intel scheme, you have the choice. MBR or UEFI.
Make sure, you copied haiku UEFI loader in the right place.
Some MSI boards appear to be tricky. You may want to tweak disk priority/disk order in your BIOS. It could help.

Hi, I had this yesterday. It was my first time installing on real hardware. First my install failed to boot, because of grub2, so I booted with something else and dd’d 1023 over the beginning and reinstalled haiku. But haiku won’t make a new MBR, so… http://starsseed.free.fr/fixmbr.zip
I unzipped that, put it on a key and ran it after I’d booted using the other key.
Kaplah! :slight_smile: boots fine now.

The “Tools” menu of the Installer application has options to write a new boot sector, or set up the boot manager if you’re using multiple operating systems.

Thanks! I didn’t see it :slight_smile: I was fiddling with a trackpad w/o a mouse. I will set it up properly going forward. As soon as I recover any desk space at all.
Regardless, it sounds like the fix.

If you enter the bootloader while booting from the USB drive can you select the SSD partition from the list of volumes and boot like that?

Laptop Dell XPS15 L502X and
Mini-PC Zotac Zbox Magnus er51060 boot a nightly haiku 64bit again from the USB stick.
For the first time too:
Laptop MSI Delta 15
~ Pretty quick to the rocket, after that is the end.
All three boats in native resolution.
The first mentioned no longer booted haiku, not even beta4.
The Laptop Dell XPS15 L502X did not show a USB stick after the underlined was displayed forever at the top left.
A message like: Find no boot partition (or similar) on the Mini -PC Zotac Zbox Magnus ER51060 was displayed - and end!
The same USB stick was used for all three computers. In addition, the same USB port was used with every boot attempt.
So please do not always take ‘wrong’ or ‘defective’ USB sticks and connections in general suspicion - which of course could also be!
(Google Translator)

It is booted directly on the desktop in English.
No question about language, etc.
Is that OK?

I hope that you opened detailed bug reports when encountered problems. Otherwise, they might be still there next beta…
Unlike on CD or on DVD, you can write on a USB stick. So, it is asking about localization once, the first time. The second time settings files are existing, there’s no need to ask again.
It also means that when you try on a second computer, you carry all settings from the first. It shouldn’t be a problem but who knows?

1 Like