Trying to port openMSX


#1

Hi All,

Just for fun I tried to download openMSX. It can emulate all kinds of MSX 1/2/2+ and Turbo R systems with 100’s of extensions and run 1000’s of MSX games. It requires SDL for graphics and sound (I believe) and that’s what Haiku supports.

The build script is very unlike linux ./configure and make system because it leans heavily on python for the compilation and dynamically creates all kind of files required. The first step was: openMSX doesn’t know haiku yet, so the Python script can detect its running on Haiku and has a X86_64 architecture but the next step doesn’t know how to build for Haiku in X86_64. I introduced Haiku to the system and try to let the build proces go as if it were Linux.

Then Python runs in to an error:
Using Python: python
runtime_loader: Cannot open file libreadline.so.7: No such file or directory
build/main.mk:440: recipe for target ‘derived/x86_64-haiku-opt/config/probed_defs.ml’ failed
make: *** [derived/x86_64-haiku-opt/config/probed_defs.mk] Error 3

This looks like python can’t find libreadline.so.7 but its in /boot/system/lib.
How to tell python its actually there?

Thanks


#2

Check, what you have installed and adjust the python files accordingly.


#3

Python is installed. What is adjust python files?


#4

You also have to install the relevant _devel packages so like readline_devel or readline_x86_devel etc… and probably alot of others.

You should probably search though the files for where linux’s lib paths are defined and fix that up… probably LIBDIR, LIB something or other.

You know it never ceases to amaze me how someone goes automake/autoconf is terrible… and then goes off and makes something just as bad or worse.


#5

Its a python error. Python seems to need libreadline for some operation and can’t find it. I installed all libreadline files. That didn’t solve the issue. The developers of openMSX are sure that they don’t need libreadline.


#6

You might want to mention this over at Haikuports if it is a problem with python.


#7

I tried to compile this, and found out that there is some problem when running the makefiles provided by the source. If you toy around with the makefile content in build/main.mk the error goes away from libreadline to libpython and i have seen libroot too.

If you tweak it to print the python commands and parameters and run them manually in a console, you get the expected output and compilation test attempts (openmsx people already say that they wanted to make it all in python instead of make)

However, the build logs in the derived-PLATFORM-i686 folder say that this needs sdl sdlfont (not autodetected just being installed, probably need some pkg-config love), glew, alsa, tcl,… And i am not sure about being a easy effort to solve all that, if you had bluemsx-libretro on the haikudepot.

In any case it is not a problem of not installed packages for readline.