Trying to install BeOS on a BeBox

As I´m trying to install BeOS on a BeBox I came across the problem that the installer hangs everytime when copyong the files to the hard disk.

This is the serial log:

KERNEL : area_resize : cannot grow area at 0x000fb000 (kernel_heap) in /boot/beos/apps/Installer (05a74000 -> 05a76000)
resize_area error
KERNEL PANIC: ** error cache can't allocate data memory

Welcome to Kernel Debugging Land:
Running on cpu 1, iframe @ 0xfd0444e0

Any ideas what the problem is and how to solve this?

Hmm how much RAM do you have inside? It’s possible there’s too much, at least on x86 there were issues with 768MB or more. There are some tricks to work around it.

I already found out that the installer seems not to like more than 192MB RAM. If I insert more than that I get to the kernel debugger :frowning:

Problem now is that the installation finishes, but the PROM can´t find the installation. As I tried to install on a SCSI2SD, I will continue to test a real HDD and other adapters.

Strange, now it worked even with 224MB RAM and now it also does work that the PROM is finding the installation. Maybe my sd card was the problem.

Hmm or it could be a bad RAM stick… memtest86+ on a PC ?

It could be possible, but I thought that the PROM is testing the memory?!

It doesn’t use all the possible patterns, it just test reading and writing to it, but some errors are only triggered by very specific patterns which memtest86 can spend a whole night to try.

I still haven´t found my Socket 7 board for testing the RAM, but I found a RAM combination so that BeOS was installed with 320 MB RAM in the BeBox :smiley:

1 Like