Trying to boot Haiku from a USB 'thumb drive'..doesn't work?

I have followed the instructions and it appears that I have successfully loaded Haiku Alpha2 onto a 4GB ‘thumb drive’ but I can’t get it to boot!

I am writing this from the ‘ISO’ cd which is painfully slow but it all seems to work. I have also tried to use the cd to boot the ‘thumb drive’ but that did not work either. The thumb drive blinked a few times but then went silent.

I installed the OS from within the Haiku ISO.

I am running an Acer5315, Celeron 560 32bit which is really a very ‘middle-of-the-road’ laptop, nothing too challenging for any OS.

I have done some forum research but come up with things that are pretty dated so I was wondering what new ideas are there for booting a USB thumb drive???

In my experience not all “thumb drives” are created equal. SanDisk uses some weird proprietary drivers that make them flake out in BeOS/Haiku…but PNY drives are great. I have some 1 GB and 4GB ones and they always worked well.

Obvious dumb question but I’ll ask: did you enable booting from USB in the BIOS?

“I installed the OS from within the Haiku ISO.”

Are you saying you used a virtual machine (like Qemu) to run the ISO and install Haiku to USB drive?

Some USB drives do not work. I can’t recall why. You can search the mailing list for the answer. I assume you have an incompatible USB drive.

You can try, running Haiku CD, mounting USB drive and running from terminal: makebootable /mount-of-USB-drive. That will write boot code to it. Still no boot. Try dd method and see if that creates bootable Haiku for you. If no, then your drive is incompatible (not working) with Haiku. If dd works, then maybe there is a way to get Haiku installed with Installer and booting.

Best to dd Haiku to the whole drive for testing if bootable.

PS There are more details on incompatible USB drive in the General or Development mailing list but the posts are unsorted when searching.

The boot loader have been reported to hang on many systems.
(see tickets #4408 #5539 #5696 and #5720)

The bug is not specific to USB thumb drives. Booting from CD or Hard-drive leads you to the exact same issue : a black screen with a white blinking caret…


@ Snuhwolf

Worth asking and I was remiss in not pointing it out in my post; yes I did, thanks!

No, I booted the CD and installed from the desktop ‘applications’ menu. The process was straightforward and appeared to be accurate and complete. In fact, I have done it more than once!!! During the process, it was indicated that there was a partition etc.

When trying to boot it just boots to the hard drive. I am, incidently, running either Ubuntu or Peppermint in a dual boot.

I have tried to boot to the ‘start-up’ menu via the CD, that is, press the shift key, and select the drive to boot. No luck in that process. The USB thumb drive tries to boot and, at the first Haiku window, the USB drive takes over until the rocket lights up and then it all just hangs.

I will take up your suggestions and see what happens, thanks!

Do you suggest that since I can boot via the CD I am unlikely to be affected by this bug?

Then the issue is different.

Your thumb drive seems to miss a valid MBR code.
Did you erase all the MBR of your USB key before you create a intel-partition-table and then a bfs partition on it ? It’s the only way to write the stage-1 bootloader (except with dd)
NB: makebootable writes the partition’s “superblock” not the disk’s MBR.(it’s the stage-2 bootloader )

If your system hangs when the rocket lights up, it can be a lot of things : a driver, an interruption issue…
you may try to “Enable on screen debug output” from the boot menu.

Can you elaborate on the expression ‘dd’ …what are you refering to???

Instructions to dd are in my previous post.

dd takes an image file, raw or anyboot, and writes (copies) it to a drive or partition. It writes over anything on that partition or drive. So, you have to be very careful using dd command.

You have two issues.

  1. Non-booting USB drive
  2. Using CD to boot USB drive which freezes at rocket icon.

For 2), it is important you get into safe mode. You can do this by keep pressing your space-bar (or holding down the left shift key) when booting. Both ways have worked for me. Trying with safe options may get you to boot or help at least to figure out what is causing the freeze.

For 1), Use Haiku’s Drive Setup to remove all partitions from that drive and initialize the whole drive as bfs. Then use Haiku’s installer. Doing it this way you remove the step of having to find the right partition to boot Haiku. Try and see what happens.

I can and have got into the safe mode and, in fact, on one occasion, the USB drive actually booted and I was able to operate from within the usb drive. It was excellent, fast and fun to use.

At last, I thought, I can get stuck into doing something creative and useful. No chance, It
refuses to boot again.

Thanks for all the help but I give up!

I eventually got a USB thumb drive booting, on it’s own, as far as the red rocket. I guess that suggests the USB is ok and even hints that the MBR is OK.

I have been trying all sort of combinations of ‘safe mode’ selections but without any success.

Any suggestions to get past the Rocket.

In safe mode try:

  1. enable fail-safe video mode + select 1024x768x32 for fail-safe video mode. This will enable VESA mode and set the resolution. If the graphics driver is causing the freeeze then this will get around that.

  2. safe mode. This will disable audio and networking. So, if you boot then you know that audio or networking was causing the stall.

I really believe the problem might be with the ATA Stack or AHCI. Are you using SATA? Is it AHCI? Can you set SATA to legacy (ATA compatible) mode in BIOS?

Read syslog, on screen debug and hardware issues sections from here:

Thanks, tonestone57, but no luck on suggestions 1 & 2

Disk utility tells me …SATA host adaptor,AHCI controller, fabric ATA

I will have to sign off to check the possibility of changing to ATA in BIOS, do I want to???

My 2 choices in BIOS includes AHCI or IDE, same thing? Anyhow, I will give it a try!

Ok, AHCI is supported by Haiku. So, thinking maybe ATA Stack issue? When you boot Haiku CD, can you mount partitions off the hard drive? How about mounting the USB stick?

The only way to know exactly what is going on is with syslog. Since you can’t fully boot, you would have to save the syslog to fat32 partition. Not as reliable is on screen debug method which may give a clue to the stall.

IDE mode is the older Legacy or ATA mode used on PATA drives. You can try it but this will only work if AHCI is the issue which I do not believe it is. Worth trying to see what happens.

Go through safe mode options, enable all of them plus use a supported video mode like 1024x768x32 and see if you can boot Haiku then.

Thanks for sticking with me Tone and I am very pleased to point out that I have finally had a successful boot-up via a USB 'Thumb" drive! Not my collection of four bigger and more recently purchased USB drives but my old reliable 2GB, fat16, Sandisk Cruzer.

Many thanks…don’t understand why the others don’t work??

I had heard that some USB drives do not work properly with Haiku. Can’t recall if anyone said why. Can be very frustrating because Haiku should boot with all USB drives but that apparently is not the case.

I usually boot to hard disk partition but I sometimes boot Haiku on a Crucial 2GB SD card.

What brand of USB drives were not working for you? That way I and others can avoid buying those ones.

[quote=tonestone57]I had heard that some USB drives do not work properly with Haiku. Can’t recall if anyone said why. Can be very frustrating because Haiku should boot with all USB drives but that apparently is not the case.

I usually boot to hard disk partition but I sometimes boot Haiku on a Crucial 2GB SD card.

What brand of USB drives were not working for you? That way I and others can avoid buying those ones.[/quote]

Some USB thumb drives are loaded with Windows software that prevent them from being used effectively. The drives I have been using have been either not effected or have had this pre-loaded software removed. They have each had various versions of Linux/BSD running on them. The USB drive that worked was one I bought in a ‘boot-sale’ in the UK for peanuts. Small but it has always worked!(SanDisk Cruzer 2GB)

Before naming names I will explore a few things. To get to boot as far as the ‘rocket’ and not go on doesn’t make sense??? There must be some way!

However, first things first, I need to explore Haiku a bit and get wireless working then I will experiment more with this USB drive thing???

I may be a while on the wireless…I read that my bcm4312, vendor14e4,device 4315 is not supported.