Trouble running Haiku alpha on Shuttle SN41G2

Hello all,

many greetings and thanks to the whole Haiku community for all the great work already done to resurrect this fantastic OS :slight_smile:

I downloaded Haiku alpha iso and installed it without any issue on an old Shuttle XPC Barebone (SN41G2) which I had already used for BeOS in the past :slight_smile:
However I am facing two issues at the time (which I assume to be related):

  • the system won’t boot unless I turn safe mode on: the desktop background and mouse pointer appear but everything is frozen before the tracker even starts and icons don’t display on the desktop. If I activate safe mode, everything starts normally.
  • once the system is started, if I turn on the media server, everything freezes and I have to reboot from hardware

Additionnally, does anyone know if it is possible to add support for the network driver of the nForce2? I saw a driver on bebits but comments on the development Haiku tickets seem to indicate there should be a driver ported from FreeBSD for this chip…

Should I try to upgrade my alpha to a nightly build?

Thanks by advance for any answers/tips… :slight_smile:


I’m guessing offhand that your video chip is also nvidia…

The “hang” you’re seeing at boot is likely the video accelerant/driver causing an issue - you’ll want to file a bug about this, with syslog if possible, at

Likewise, you should open a separate ticket about your network chip. Several nforce network chips are working in Haiku, so it may be a simple task to fix your issue.

Yup, actually I’m not using the onboard nForce2 IGP graphics chip but an AGP GeForce 6800-NV40 (because of the DVI output). There is a driver for it on bebits ( but it seems a little old and I think it’s already included in the Haiku alpha distro? Otherwise I can have a try with it…

I haven’t found any syslog on my computer, actually I don’t even have a “log” sub-directory inside the /var directory (I’m assuming I should have found the file to be /var/log/syslog).
I’ve modified ./config/settings/kernel/drivers/kernel to change #syslog_debug_output false into syslog_debug_output true, I have uncommented the syslog file size line (that should enable it to reach 20M) and also uncommented the apm true line. APM works :), but syslog remains inexistant… Maybe Haiku tries to create the file and fails because there is no such directory as /var/log? But I thought /var was a virtual structure??

Before I file a bug, I’d like to make sure I can get my hands on syslog :slight_smile: and I’ll also have a try with the latest nightly build, just in case parts of my issues would have been fixed since alpha. I don’t fear breaking anything as I have fully devoted my good ol’Shuttle to Haiku testing/dev/stuff/whatever :wink: and there’s nothing else than Haiku on it right now.

Could you please help me finding where syslog might have gone?

You can’t navigate to /var/log from Tracker, you must do it from a terminal.

from a terminal, you can:

open /var/log/syslog

which should open it up in StyledEdit.

In any case, unless you’ve disabled the onboard graphics, that may be part of your problem. Haiku has a driver built-in for the nvidia cards. Any driver you find on bebits is probably just an ancient BeOS version of the driver included with Haiku (the Haiku nvidia driver is maintained by Rudolf).

You should definitely file a bug.


I’ve filed a bug (

Actually I’ve tried to access /var/log from the Terminal.
I’ve cd to /var and then ls does not list me any log subdirectory in it.
I also tried to call find -name syslog from the root directory / in the Terminal but this just made CPU jump to 100% and I had to kill it after 5 minutes without result.

I am suspecting an audio problem because fail-safe video/VESA doesn’t help, but if I boot in safe mode and turn media server on, everything hangs/freezes instantly?? Or, reading your answer makes me think of it, maybe I didn’t properly shunt the onboard graphics in the BIOS and Haiku gets confused between the onboard graphics chipset and the added AGP GeForce 6800?

Of course trying with the nightly build from December 12th didn’t help :frowning:

I’ll try to do some more tests in the coming days.

to get syslog file, boot in safe-mode and enable console debugging - that should create the file for sure.

yes, with media server freezing or hanging sounds like an audio issue. in your ticket, provide listdev output ( very least for audio & video since they sound like problem areas ). Once developer knows your audio card, they can work with you to fix the issue.

You should have separate tickets for each issue - audio, video.

Also, provide your interrupt info like Stippi commented on your ticket to rule that out. Since this could likely cause your crashing & freezing issues too.