Trouble Booting x86 Haiku on Dell Inspiron E1505/6400 Laptop

I am using the latest anyboot image on a Dell Inspiron 6400/E1505, a 32 bit machine with 2GB of RAM.

It boots fine on a USB3 stick connected to a USB2 port. When I install it to a 500GB mechanical SATA HDD, it reaches the Haiku boot loader (I did eject the USB drive) but it doesn’t find the boot volume.

My bios is up to date. Booting as MBR. This laptop doesn’t even support UEFI.

Is Haiku the only OS on the HDD? It’s not uncommon for people to erase the drive but then format the raw drive as BFS instead of creating a partition and then formatting the partition as BFS.

formatting raw with bfs works just fine, provided you use csm or bios boot.

One issue I have had is that the installer would not overide the boot sector of the partition table if i just delete partitions on it anf use it as is by adding new partitions.

Perhaps the installer needs to then overwrite the partition table boot sector (afaik drivesetup doee this when adding a new table.

In any case: hard to know what is wronh above, is the issue that no bootable devices are found from the bios or the haiku loader?

A ticket would be nice in any case.

It could perhaps be useful if you write the partition list here. You can use DriveSetup from the USB stick for this.

And what is the exact output of the installed bootloader before and after selecting a partition?


BeOS was the only OS on the drive. But I deleted the existing Windows partitions in DriveSetup and then manually created a BFS partition and marked it as bootable. It does reach the haiku bootloader menu.

Now that I am thinking it through, I ran Drivesetup and the installer after booting up the full operating system (which was running on the USB drive). I should go back and recreate the usb stick and install it from the install part of the usb drive, rather than from Live USB.

This brings up another idea, the ability to boot a haiku volume that resides on an external device from the Haiku boot loader. But I realize that the legacy of MBR/CSM creates roadblocks to this, and that UEFI booting makes this possible, IMHO. (Example Windows 8 Enterprise and it’s Windows To Go feature [reference: How to Create Windows To Go (WTG) Drive Manually])

Another thing to note is that when I formatted the drive initially, it was connected via a usb to sata adapter, and was later plugged in to sata.

Can you please point me to the proper procedure for a haiku install?

I will file a ticket if time permits.

It would help if you make screenshot of DriveSetup and post it here.

There is no functional difference, don’t bother : )

Installing on a drive without bootloder doesn’t worl with efi either. In both cases you just put the bootloader on the same drive, what is preventing you from doing that?

In any case: please file a ticket

The issue can then probably be reproduced and fixed.

Press shift or space during boot to access the boot menu
Go to “select boot volume”
Select your boot volume
Go back to the main menu and select “continue booting”

Not sure what’s impossible about this since it has worked for years (if not decades) already :slight_smile:

Here is a screenshot of DriveSetup. The Be HGST 465GB’ is the volume and disk in question.

Why is the haiku partition only 710 MiB in size?

It looks to me as if Lrrr is right: The whole HD was formatted, not a partition.

I don’t know the bootsector code of Haiku. But I guess it is done this way: Bios → MBR → partition bootsector → kernel. This might break if there is no partition. Probably the bootsectors try to calculate the start sector of the partition, which fails without a proper MBR-partition-table.

That is the usb installer.

ok. I am familiar with the BeOS setup and this is my first time with haiku. I will open a ticket since maybe the language in installer could be updated to reflect this subtle difference.

As I have already written above: this works fine.
there is no technical reason why you would need a partition table for bios boot, you only need a bootloader, which haiku writes.

Correct in theory, but not in practice…

For some reason, many modern BIOS will not try to boot from a device if they don’t see a valid partition table on it. So you really want to add a partition table for that case. This is not how it was originally done, but this is how it works now on many machines.

I renamed the thread for others who come here for this PC.

I finally got it to install and boot from the HDD! And it boots via external usb/sata adaptor, so it’s portable too! Haiku rocks!

Another oddity I see related to this hardware is that, with Haiku running, it only mounts standard ISO9660 and joliet CDs. It will not mount BeFS formatted CDs or boot from them. I tested with BeOS Max 4beta1 and the BeOS Pro CD 5.0.3 X86/PPC on This is likely a hardware issue, since this machine can boot a Windows 2008 DVD. Once I have the time, I will pull out the drive and post pictures of it. If I want to burn CDs, I will have to find a drive that fits this slot.

1 Like

Would you mind sharing details?, that way others might benefit from your experience.

I kept the BFS partition under 120GB rather than the whole drive. Also from the other posts, I figured out that I should format the drive first, then create the BFS partition, then format the BFS partition.

Also Balena Etcher does not work on Windows 7 32bit. Win32diskimager and the other rawwrite type of utilities do work. When we have installation documents, they should probably reflect this.