Thinkpad X1 Carbon 5th Gen: WQHD Support


#1

Hi, can anyone tell me if Haiku supports WQHD (2.560 x 1.440) displays? I am thinking about installing it on a Thinkpad X1 Carbon 5th Gen with Intel HD 620 graphics card and would like to use the widescreen at full resolution.


#2

If your Intel HD 620 has Haiku video driver and not work in VESA than it supports, I think.
For example:


…Of course if your video chip support that resolution also:
https://communities.intel.com/thread/112598


#3

Sounds great! Thank you! I will try it as soon as it has arrived…


#4

Konstantin, please report back as you gotvsome experiences with it. Thanks!


#5

As much as I would like use Haiku and report back, the Thinkpad does not boot from my USB sticks.

I used dd on Mac as well as Win32DiskImager to copy the haiku-nightly image to the stick. But after entering the boot menu, selecting the stick and pressing enter, it just turns black for a second and does nothing.

Are there any more convenient ways to install haiku or ways to sort out this issue?


#6

Konstantin,

Haiku has a safe-mode boot option which could help you diagnose the issue(s). See https://www.haiku-os.org/docs/userguide/en/bootloader.html . You may have to boot with a lower and safer screen resolution.

Which release of Haiku did you put on the USB Stick - R1 Alpha 4.1 or the most recent nightly? The most recent nightly may have the needed video support (if this is the underlying issue).

Did you try one of the popular Linux distributions? Or browsing their forums for booting from USB issues encountered with your X1? This could help you ensuring that as currently set-up the X1 will boot from a USB stick.


#7

Thanks for your suggestions!

I am using haiku-nightly-hrev51428-x86_64 and I cant get past Thinkpad´s own Boot menu. It does recognize the USB stick, but Haiku itself doesnt even start to boot.

I just tried it on another old lenovo netbook and it does not boot from the stick either. I followed the instructions on https://www.haiku-os.org/guides/installing/making_haiku_usb_stick/

Is there anything else I need to do before, like formatting the stick to a specific file system?


#8

Are the USB ports on the X1 and the older Lenovo netbook only USB 3?

Haiku has unfortunately a number of issues related to USB 3:
https://www.haiku-os.org/blog/kallisti5/2017-07-17_bug_xhci_usb_30_issues/ .

On real hardware, the XHC! bugs may cause:

  • Problems booting from USB drives
  • Crashes transferring data over the USB bus
  • Crashes and kernel panics at boot while Haiku examines the XHCI bus.

Also, as far as I understand, the 64 bit version can be finicky.


#9

Ah, that might explain it.

I am not sure about the old one, but the new one has USB3 only I think. I wrote Haiku 32bit to the USB stick, as well, and it does not even start to boot, either.

What would be the next attempt? Burning a CD and use an external CD drive? Or is there anything better I can do?


#10

There seem to be something else than USB3 or graphics card support involved here. If it was one of these, you would at least see the Haiku logo or at least the early boot menu (in which you can tweak safemode and the like). If you don’t get there, the compatibility problem is at a much lower level. It can be either:

  • The USB stick and the BIOS are not compatible,
  • User error when creating the stick, for example writing the image to a partition instead of the whole disk,
  • Machine is configured in UEFI mode instead of BIOS or/and has “secure boot” enabled,
  • Or possibly a problem in the early code of Haiku (stage1 or stage2 loader) which prevents even getting to the boot splash or boot menu

If all the first causes are shown to not be there, and we are left with only the last one, the only way out would be to use a physical serial port to get a boot log out of the machine (which is not possible on most laptops from the last 20 years). However, I’d say it’s likely to be one of the other problems.


#11

I think that using one of the popular Linux distributions as a test would help diagnosing the issue(s) in this case:

  • Not all USB sticks are created equal and the stick could be incompatible with the BIOS.

  • Switching from UEFI boot to Legacy boot often requires two flags to be set-up in the BIOS: 1) Enabling Legacy BIOS and 2) Disabling secure boot.

Searching about issues encountered in booting the “test” Linux distribution from a USB stick for that particular X1 model would provide additional clues.


#12

Switching to Legacy BIOS and disabling secure boot led to booting Haiku!

Unfortunately it runs into:

PANIC: get_boot_partitions failed!
Welcome to kernel debugging land…
Thread 18 “main2” runnning CPU 3
stack trace for thread 18 "main2"
kernel stack: 0xfffffff

etc. I tried it with 32 and 64 bit versions…


#13

Now that looks like lack of USB3 support. Either that or some other reason makes the Haiku kernel unable to find the filesystem on the USB drive. If you have an USB2 port on the machine, or if USB3 can be disabled from the BIOS setup (sometimes labelled xHCI there), maybe try that.

There is work in progress to support UEFI, and we should also investigate improving our USB3 support at some point.


#14

I could not find any option to switch to USB2 in the BIOS nor do I have a USB2 port I think.

  • What´s the next best way to physically install Haiku?
  • Also how do I make the USB sticks usable again? Formatting them does not work anymore.

#15

There is no Enable USB legacy support in your EUFI BIOS?


#16

I would removed hdd or ssd and installed Haiku on another machine which boots Haiku. Also you can try to clear USB stick from Linux Gparted or similar app on Windows wich can do partitioning.


#17

Oh yes, I enabled this. I even can define the order. But it results in another error.


#18

For installing, maybe the old trick of using BeWrite discussed under
http://betips.net/1997/09/09/installing-beos-on-laptops/ needs to be revisited and adapted for Haiku?

The HP USB Disk Storage Format Tool 2.2.3 apparently handles well challenging formatting situations. The utility can be found from many sources on the web.


#19

Has anyone tried again running Haiku on a Thinkpad X1 Carbon since the Beta 1 release?


#20

Until XHCI is working fully… it won’t be booting from USB.