Texinfo failed to download

When I try to update R1b4 32-bit, I get the following message:
texinfo failed

Which version of texinfo is Software Updater saying it is going to download?

Try installing with “pkgman install texinfo” in Terminal, maybe it produces some more usefull information?

Software Updater is trying to download texinfo 6.1-7

pkgman install texinfo

show more details

6.7 had been obsoleted in favor of 6.1 (requirement issue). Think it’s strange that it would error out on it, not sure if it’s another issue here? :confused:

The expected “checksum” looks like a bit of HTML and it also says it failed to refresh the Haiku repository. This can happen if you tried to install updates while using a network connection with captive portal (so the update attempt downloaded the portal login page instead of what it expected).

I think the simplest way to get out of this is to delete and re-add the repository (you can do this using the pkgman command line or using the Repositories preferences).

I think the package kit could do a bit more validation of the received data, and not accept a random HTML page as a valid checksum?


I uninstalled texinfo using pkgman. Then I tried to re-install it.
pkgman install texinfo

It’s trying to re-install a previous downloaded package, you could try to remove that directory (state) containing the package.

All is well. I deleted the incomplete texinfo package and then I could re-install texinfo.