Testing Haiku (First install) Acer Laptop

Greetings Everyone,

I am new to the Haiku community and recently just discovered Haiku. I wanted to detail to all of you my install and experience with Haiku. Below is the model number and stats on my computer.

Acer 3680-2682 (Laptop)
Intel Celeron Processor (1.86 GHZ, 533 MHz FSB, 1mb L2 Cache)
14.1’ LCD
Intel Graphics Medica Accelerator 950
DVD/CDrw combo drive
512 meg DDR2 Ram
802.11b.g wireless LAN

Let me say first that I can agree with what is said on the website. Try the anyboot CD it actually is seemingly better at getting the install done. I tried with the CD a few times on three different systems and was not able to get it working (Could be a bad cd, but I burned three of them and nothing. I used the anyboot ISO and installed it to a USB stick and Voila!!!

Anyway, let me detail my install for all. First off, this particular notebook came pre-installed with windows Vista. The system was so fickle that I couldn’t take it anymore. So After a few weeks of fighting with it I installed Ubuntu Linux. After that all issues were resolved and it worked fine. Upon discovering Haiku, I didn’t want to get rid of Linux but at the same time my Linux install utilized the entire 80 gig HD. I had to figure out a way to get Haiku on yet still retain my Linux install. I decided to fire up Linux and use Gparted. Gparted is a great tool and for those who don’t have it, get it!!! trust me it comes in really hand. Using Gparted I re-sized my hard drive partition and chopped off 20GB from the Linux partition. MY Linux partition wasn’t affected and it left me 20GB to install and test Haiku. I tried and tried to get the CD (ISO burned to CD) to fire up but nothing worked. Strangely though, the cd would start to boot up and kind of get frozen (Continue spinning) and get stuck. If I ejected the cd then it would boot into Haiku. I decided to forget the CD altogether and use the anyboot ISO set up on a thumb drive. I partitioned the thumb drive and used one section for Haiku and the other section for all sorts of data that I wanted to test on Haiku (I set up one partition with the install and the other partition as NTFS). The Thumb drive fired right up with no issues at all. I immediately selected installation from the menu (Click on the haiku symbol and go to applications/installer). I selected the free 20gb and followed the prompts and had it format the partition with the Befs file format and clicked install. It worked without a hitch. (I have no idea what the issues with the CD were but nontheless they were present).

After install, I tried out a few of the systems. I restarted the computer and I must say that even on this old system Haiku boots lightning fast. Everything seemed to work right out of the box. CD drive working (I haven’t tried to burn a CD yet, as stated new to Haiku and still learning about it). My network card works without trouble and I tried the net it works fine. Mouse working, Speakers work fine with no additional software (Both internal and headphones). I have yet to try the WIFI. I tested a couple of files to see how it handled them. I tried the media player and tried the following file formats/ MOV, WMA, MP4, FLV, MKV. Video formats. It handled each like it was nothing. In fact I had multiple windows open and each one played flawlessly without slowdown. (Not something I can say for the other systems. In fact some of the systems I have used have trouble with some of these formats.) On to music, WMA, MP3. I tried several different photo formats also. Handled all of it without a hitch. (All of the files were installed on a hard drive (NTFS formated and read only for Haiku). I will continue testing Haiku and must say that I am hooked. I look forward to experimenting and in a few hours I will attempt to install on my PC which is top of the line and filled with hardware.

On a side note, I forgot to mention that I had to edit my grub boot menu in order to be able to boot both Haiku and Linux from the boot menu. Otherwise the system booted directly into Linux and did not recognize Haiku. (It didnt recognize it even after I updated Grub2). I edited it and per instructions on this website I simply added a few lines and it worked. Edit this here:: /etc/grub.d/40_custom. I added a line like this: