System reboots on usb install


#1

I suspect this may be a hardware incompatibility issue, so I’ll begin by posting my specs here:

CPU: AMD Phenom II X6 1055T Processor 2.80 Ghz. 6 cores.
GPU: MSI Nvidia Geforce 950 2GB DDR5
Motherboard: Asus Crosshair IV Formula
RAM: 8GB of DDR4

So here’s what happens: I flashed my usb drive with Etcher (I first tried with Rufus; same result), I selected it during boot, and then my computer restarted.

I really want to try Haiku out because I feel like it could be useful, and because I would like to contribute to it. Can anyone help me?


#2

Can you provide a bit more details? What do mean over “my computer restarted”? You have selected your USB as boot device and then pressed Enter and instead of booting HAIKU your computer just gets restarting?


#3

Yes, that is exactly what I mean. The computer just restarts.


#4

First try to enter Haiku boot options, by holding shift or smashing space at boot. Then play with options Safe mode, Video safe mode, ACPI disabled/enabled and 4g RAM limit.


#5

If the computer reboots instantly, it’s probably the case that one cannot even get to the bootloader menu.

@kackiz, can you try using the EFI loader? Often that avoids these kinds of issues.


#6

This is the same thing that happened on my Phenom II X4 (I don’t remember what motherboard is in that one). I wasn’t able to get to the bootloader menu.


#7

Do you see any indication that HAIKU is attempting to boot, or your machine is just going straight to reboot?
What if you try different USB stick?
What if you try to use your USB stick to boot some Linux-live distro?


#8

EFI loader is still just the 64bit images right?


#9

I have tried holding shift and nothing worked. Will try space and see what it does.


#10

I don’t think my computer supports EFI, but I will try.


#11

I have used the same USB stick whilst installing many other Operating Systems. I will still try another one, just in case.


#12

I checked, and it looks like the computer was already doing it for me.


#13

tried to hold downspace and shift but nothing worked.


#14

Maybe this would have been of help, but what specifically happens is:

After I select the boot option by pressing F8, a white cursor on a black screen appears, the monitor shows a message of no display, and the computer restarts the booting process.


#15

Which image of Haiku did you download and try? We need that information just copy and paste the filename here. If you tried several list them all and what happened with each one if there was any differences.


#16

I downloaded haiku-r1beta1-x86_64-anyboot. I guessed it was the stable release, and the nightly builds weren’t so stable.


#17

I also tried every suggestion given and nothing worked.


#18

You never tried a 32bit build or a nightly though? If not then please do. The 32bit builds lack UEFI so will force booting via CSM or BIOS support. The nightlies may have a fix for your booting issue as somethings have been worked on there recently.


#19

I finally tried the 32-bit nightly distro, and it din’t work either. Oh well.


#20

Does your USB stick boot on other computers? It’s possible something is wrong with your USB stick also.

Also it appears that there are 2 USB controllers on your computer one is USB 3.0 (2 ports on the back try that) and the rest are USB 2.0 form the chipset.

https://www.asus.com/us/Motherboards/CROSSHAIR_IV_FORMULA/specifications/