Switched to Haiku: What doesn't work(yet)

Good day,

This is a companion post to the Switched (Switching) to Haiku topic I started in 2020. While that one is to share the experiences of the switch, this one is to identify what is not working at the moment.

By the way, by no means this is a complain. It’s just to keep track of things.

I will be changing and updating the list the moment any of this items starts to work properly. Rembember that these have already their tickets in the bug tracker, or at least, most of them.
I tagged them with an importance level, though that does not mean that I can’t circumvent the issue, so I post also the temporary solution I use while the issues aren’t fixed.

  • Audio
    I’m on team red (AMD Ryzen+Radeon), with audio coming out from the display, connected via DP and USB to the box. Right now I have no audio out.
    On the other side, all the audio devices I’ve been gathering through the years are all USB, mike, FX processors, MIDI keyboard, which are not yet supported for audio in, so I can’t record any music.
    Temporary solution: use Linux or Windows for audio production
    Importance: ***** critical

  • Digitizer
    While there is support for Wacom tablets, I don’t have yet stable support for the Huion digitizer, and also for the digitizer pen that comes with the Asus tablet. This means that I have to use the mouse for graphic design. Problem is that once I started to use the digitizer, there is no way back to mouse. The difference is big.
    Temporary solution: use Linux or Windows for digitizing graphics
    Importance: ***** critical

  • Video out - Multimonitor
    After pimping the Vaio laptop, I plan to use it for keynotes at meetings. This old laptop only has a VGA out port for audio, which does not work. Sometimes even causes a trip to KDL when plugging a display to the VGA out port. Also no way to use two monitors or a monitor and a pen display at the moment.
    Temporary solution: boot the laptop with a Linux pendrive for Libreoffice Impress
    Importance: ***_ _ somehow important

  • Phone file exchange
    I haven’t yet got the android phone to transfer files to and from Haiku, even with the program Android File Transfer available in HaikuDepot (this I need to report in bug tracker). I haven’t tried yet with the Pinephone running Linux, though I don’t expect any difference.
    Temporary solution: transfer files using Linux
    Importance: ***_ _ somehow important

  • Hardware 3D acceleration
    Right now I’m on framebuffer video driver with my Radeon card, and at the moment there is no way to get hardware 3D acceleration on this box. Nonetheless, the game projects that I have in the queue are two 2D and one 3D, and the 2D ones go before the 3D. As my development pace is quite slow, when I reach the need for the 3D accelerated hardware, maybe the situation on Haiku has improved. Who knows.
    Temporary solution: use Linux or Windows for certain specific 3D tasks (not in a rush though)
    Importance: ***_ _ somehow important

  • Blockchain
    This year 2021 is the year of changes. Besides the switch to Haiku, I’m trying to deGAFATize (no Google, Apple, Facebook, Amazon, Twitter) my social networking, and I’ve been doing some research on alternate social networks. Many use the blockchain tech and some even need some sort of Blockchain Wallet software or Browser extension available in order to work properly. I haven’t seen anything regarding blockchain on Haiku yet.
    Temporary solution: use Linux or Windows for blockchain social networks, or do more research
    Importance: ***_ _ somehow important

  • Online banking
    Well, the state of browsers on Haiku is a bit “muddy”, not just for rendering websites properly, so I don’t feel very safe to do anything regarding this topic on Haiku just yet.
    Temporary solution: use Linux or Windows for online banking
    Importance: ***_ _ somehow important

  • Deal online with Public Administration
    Each Public Administration has its quirks, and in many cases only certain browsers are “recommended”, and certain apps are only available for those OSes, and will must be used with such browser, none available on Haiku yet.
    Temporary solution: use Windows and Internet Explorer
    Importance: *** _ _ somehow important (though it’s becoming more important lately)

  • Videoconferencing
    As far as i know, there is no support for webcams yet on Haiku, so there is no way to do videoconf. It’s a good excuse to not use some videoconf software whose name starts with Z. But in some circumstances it’s becoming a need, even for online classes for kids. Guess we’ll have to keep using other OSes for that at the moment.
    Temporary solution: use Windows
    Importance: ** _ _ _ pfff… not that important yet

  • Encryption
    I haven’t found an easy way to encrypt files/folders/drives on Haiku yet.
    Temporary solution: none that I know of
    Importance: *_ _ _ _ not that important yet

  • VR/AR
    In real wishful thinking, I would be making the next AAA VR/AR game. That ain’t gonna happen in the near future though bro’. I know there is no chance to do any AR/VR on Haiku, but maybe when I reach a stage where I’m able to do AR/VR, Haiku already has that implemented. I’m slow, so it will take lots of time on my side… XD
    Temporary solution: complete the first stages first, then learn AR/VR, then think about that
    Importance: _ _ _ _ _ not important at the moment, though for 3D stuff AR/VR is becoming more and more relevant.

Those temporary solutions, once I find a Linux distro that is low on resources (maybe Puppy) and runs smoothly enough on QEMU, could be done without booting the box into another OS, which will make everything easier.

I will be removing these items from the list when I have them working, or if anyone else notifies that they are solved and thus can be removed.

Thanks all.
Regards,
RR

5 Likes

USB midi keyboard is supported

USB midi?
I did not test my keyboard with USB-cable.
Are you sure? I use a Yamaha YPT - 410 digital keyboard.

yes, i have a usb midi keyboard from nektar.
In haikudepot there is an application called midi keyboard or so that can visualize midi events.
For playing them back you need to install a soundfont from haikudepot, and then you can use midi play with live input mode.

Can you make some screenshots and a description for our knowledge base?

For phone file exchange I remember somebody worked on it so MTP used by Android to be able to connect to Haiku. I don’t remember the name or the latest status. Additionally something was done also for iOS as well.

Yes, there’s an app on HaikuDepot for file transfer via MTP. It works when I tested it too!

Good day @nephele,

It might be supported under certain conditions. Here it’s not:
screenshot1

Terminal shows that the Korg microKEY is there connected through USB. There is also a sound font installed, though the Media preferences shows “it ain’t me who deals with that”, and the installed sound font does not appear in the media prefs.

Trying to use Musescore with the microKEY results in no input at all. Only input through the mouse/keyboard is available. In fact, no signs of the microKEY all over Musescore’s prefs. I might be doing something wrong, or I might need to set up something else. Not sure about that though.

Regards,
RR

1 Like

Hey, I have no idea if the musescore port has any support for our midi kit.
The soundfonts really should show up, perhaps you need to restart the media services once for that to work (or reopen the panel)

After that you can use app/MidiPlayer and set it to live input for the device you have

Good day @nephele,

The font showed up upon restarting the computer. Restarting the media services didn’t do it. And launching the MidiPlayer just crashes the whole OS… sends me to KDL with no way to save a report, that’s when I had to reboot and then the sound font appeared there. So no way to test that out yet.

Regarding if Musescore has support for Haiku midi kit, I have no idea too. The preferences for note input shows that MIDI input is enabled, but the I/O preference does not show any device available, just “Restart Audio and MIDI devices” though nothing happens there. I presume I should report a ticket on Haikuports regarding this.

Thanks @nephele.
Regards,
RR

I at least have code written for basic audio support here: https://github.com/CodeforEvolution/MuseScore/tree/haikuAudioSupport

But unfortunately it doesn’t include midi support, and it will need to be rewritten for MuseScore 4, as they are currently completely rewriting the core of MuseScore.

1 Like

There is actually a midi_server which seems to act as a roster for MIDI devices and applications. I am not on a development machine but I am browsing the source on GitHub to get some idea of what it does. I don’t see any current bugs logged against it but my suspicion might be that various aspects of it are not working right. The fact that running MidiPlayer causes a KDL is not good. Of course that may be due to the sound font or the connected devices.

I don’t know how the sound fonts are supposed to work or what system component loads and manages them. I don’t see much in the midi_server code about that. I don’t see any add-ons related to MIDI.

Maybe this is not much help but I was curious to look into it. I have some interest in MIDI stuff myself but don’t yet know much in general or how it works in Haiku. I think it would take some time to get up-to-speed.

1 Like

From what I know, MIDI devices work fine here. There may be bugs in some of the USB drivers and I think someone mentionned a SMAP violation in the MIDI drivers but I didn’t see a bug report. In a post above a KDL was mentioned, but also no bugreport. How do you all expect bugs to magically disappear if you don’t report them to the bugtracker?

Anyway, here is what you can check:

  • The soundfont is used by our internal MIDI synth which is based on fluidsynth. Media kit is not really involved here.
  • You can see your MIDI devices and apps in PatchBay (which is the equivalent of Cortex for the MIDI kit) and connect things together there or just visualize connections
  • For testing, you can enable “direct input” in MidiPlayer and it will use events from your connected MIDI keyboard

That was me in xhci, Havent opened a report yet since my track credentials are on my old computer and i don’t know them by heart.
I did however make a photo so will do that soon~ish