Stuff not working in recent hrev

I installed hrev 50559 the other day, and a couple of facilities that have always worked to this point seem to be inactive in this version. Thought I’d ask here before submitting a ticket.

Most vitally, the “Open Terminal” Tracker add-on doesn’t work! As this is a feature I use many times an hour that’s a bit limiting! Most of the other add-ons, like ZipOMaticand FileType work as normal. I can’t see anything missing.

Secondly, the “About Haiku” Deskbar item has no effect (though the
AboutSystem app is OK).

Anybody else seen this? Any clues? I did install over a rather old partition, but as everything is in /boot/system I can’t see that being

Addendum: I realized that one thing that might have been inherited from the old version was settings, so I made sure all the old stuff there was moved out of the way. This made “About Haiku” work, but the Terminal still doesn’t come up.

I use 50563, which is a a few days newer than yours and I don’t have those issues. But in the past I have completely wiped by Haiku install before trying a new hrev, I mean, like installing another os then reinstalling Haiku.

In general I don’t want to wipe a partition, because I tend to store extra stuff all over the place – wherever it happens to be convenient. If there’s any clash, I can normally find where it is and resolve it.

This time I’m still at a loss. I moved the entire ~/config hierarchy out of the way and reinstalled from an image. Booting the result just gives me a blank blue screen! The cursor works, but there’s no Deskbar or Tracker – not even a logo – so I can’t do much! Put the previous config back, and I’m back where I was. Mostly normal, but no “Open Terminal”.

Any other ideas?

Eh, heh… Solved, mostly. It was finding an ancient Terminal, which doesn’t work these days. Somehow the infamous but little known ‘PPATH’ attribute on the mime_db entry for Terminal got set to that. [I have no idea how.] I’ve just cleared out mime_db and let things get reset. Seems OK so far.

The remaining mystery is why reinstalling after removing the whole of config failed to start a full system. Think I’ll ignore it…