Stuck in debugger

Hey there, me again.
So I’m facing this now when I try to boot and have been for a few days, it got caused by me changing the system fonts, and I decided to wait a few days so I didn’t spam the forum. If the image is unclear, I can get better ones, but I can’t get you a syslog because I have no way to get it off the hard drive and onto something with internet access.
Edit: this happened, but it’s not particularly helpful.

Actually it’s not KDL but the userland debugger in terminal mode because a thread in app_server crashed.
Looks like some memory corruption…

1 Like

If you can reproduce it type save-report, wait for a few seconds for the report to be written and reboot. It should appear on your Desktop. Also you need to open a ticket for that bug at This forum is not the right place for bug reports.

1 Like

Good day,

Does it sound like this one:

Something similar happened to me when trying to change fonts in Vision. The report added to the ticket was the app-server crash report.

Didn’t know that until now. Another thing learnt. :slightly_smiling_face:


1 Like

I can reproduce it, the problem is I can’t stop reproducing it. I therefore can’t get any logs off it and onto this forum because I don’t have anything else with Internet access; i’m typing this on my phone and Haiku is the only OS on the laptop that boots.

Hey, you can try booting into an earlier state from the boot manager, that state should then not have the offending fonts installed.
Do you still know which font caused this?

One of the default monospace fonts, I can’t remember the exact one. I’ve tried an earlier state before, it didn’t work but it might if I try again, I’ve had Haiku be unpredictable like that before.
Alright, just did. Surprisingly, it actually got to the desktop for a second before crashing again.

The last major change to font fallbacks was

Maybe you can try booting to a state earler than that, then

If you can boot Haiku from a CD or an USB key, then mount your disk (it will appear as Haiku1), go to /Haiku1/home/config/settings/system/app_server, copy the fonts file somewhere so we can know later what font was the culprit then delete the file.
Reboot on your disk, you should have your desktop back.
Then, if you want to analyse that file, go into the folder you placed it, open a terminal and type message ./fonts


Thanks, it worked. The troublesome font was Anonymous Pro.

1 Like

Glad it helped.
If you didn’t already, open a ticket, indicate your Haiku version and rev., of course the culprit font, the locale you’re using and don’t forget to put a link to that thread. If devs can’t reproduce it, at least they will be able to refer to the pics you posted.
If someone hit same bug before a fix is found, it will also help them to find solution here.

I can reproduce Anonymous pro regular crashing the app_server

1 Like

With Fontboy the general preview with all fonts works, individual preview crash.

Did you installed it trough the package manager? Could you test the latest version from upstream?

Fontboy itself works, but if you click on that Anonymous pro font, it triggers the same bug.

However ot sound stupid, but fonts does have version numbers, the one packaged in HaikuDepot is 1.002.001
According to their webpage it seems to be the current one.

I’ve tried with a commit before that one, in case I broke something there, and get the same crash. Also with an older beta2, both in x86_gcc2h and x86_64.

I’ve not played a lot to be sure, but setting hinting to off seems to guard against the crash; I think the part of freetype that leads to it is only used with hinting. It doesn’t solve the real issue and you’ll have an ugly desktop, though.