Strange keyboard behavior

Today arrived my localized and “haikuized” wasd mechanical keyboard, it works perfectly under windows and linux, I tried also on different computers, but in Haiku it has a strange behavior:
when I press keys nothing happens, if i keep pressed a little longer, it keeps the key “pressed” (not physically) for loooong time. Num lock doesn’t activate. It isn’t usable at all.
Behind the keyboard there’s a dip switch, I tried to set it as programmable and non programmable, but nothing changed. Do you know if there’s a problem on these kinds of usb keyboards?
Tastiere_fur
I hope in a solution, it’s a pity to have the leaf image and cannot use it under Haiku.
Any help is welcome

Forgot to mention: other usb keyboards work fine

sooner I’ll post the syslog

Not posting here, this is a part for the bug tracker

Ok, I thought it would help to find out if it’s known that these kind of keyboards are not supported. Or maybe I’ve set something odd in the dip switch.
If not I’ll open a ticket for that.
Thank you for your clarification :slight_smile:

Bug reports are also accepted for enhancements. Your hardware works in other systems and not in Haiku, so it is obviously a problem with Haiku.

When making a bugreport, please also include the HID descriptor for the keyboard (it is automatically saved in /tmp when the keyboard is connected, and is named according to the device and vendor USB IDs). Maybe we can see something unusual there.

2 Likes

Thank you for the tip, I’ll do it asap

A friend of my uses programmable keyboards a lot (apparently he macros basically everything), most of them show up as several composite devices (basically it shows up as several keyboards). In any case the weird configuration of those could potentially cause issues.

1 Like

I use qmk on my programmable keyboard and I know that qmk can send unicode characters directly or do some other magic trickery for localized characters.
Maybe your keyboard uses qmk or a similar firmware and Haiku doesn’t support that.

It might also be helpful if you run xev on linux and show the output of some key presses and releases of a couple specific keys that do not work under Haiku.

Sunday 3 I’ll do that, anyway all the keys send the right code (qwerty) and all the keys doesn’t work as they should in the way of keypress/keyrelease (sometimes keypress is not recognized and when it is recognized it looses the keyrelease event for a period of time, maybe a video can help). In the meanwhile I can ask something specific to WASD if someone can address me.