SSH Passwordless Authentication

I’m having a problem with remotely accessing my Haiku system through SSH with passwordless authentication.

Both on my client (Linux) and my server (Haiku), I ran these commands:

useradd sshd
passwd $password
ssh-keygen -A
ssh-copy-id $remote_system_ip

And while Haiku will generate a pkcs key file, and send it to my remote system,
it will only work one way…

I can login to my remote system through Haiku without a password, but my host will still prompt me for a password when trying to login to the remote Haiku system.

I have already ensured that a password is set, and that the user sshd exists,
and PermitRootLogin has been to yes in /boot/system/ssh/sshd_config.

I’ve scoured forums for any leads, but I cannot find anything regarding passwordless authentication over SSH for Haiku. And the presence of ssh-keygen and ssh-copy-id on Haiku would suggest to me that it should work… if not, then I was misled.

Some further details,
I’m running Haiku r1/beta4 under QEMU/KVM on a Linux host.
And my virtual network is setup properly, and I can successfully login
to other physical systems on the local network with the key pair.
This is purely a Haiku problem.

You can check some details here : Network password not being saved - #5 by PulkoMandy

Thanks… but it didn’t help.

The sshd user already exists, and I set my password already.
And the sshd_config file is set to `PermitRootLogin yes’

I’ve just tested with beta4.
Generate ssh key under Windows (mobaxterm) and copy pub in /boot/home/config/settings/ssh/authorized_keys in Haiku VM.
From Windows, i connect directly to Haiku VM using “ssh user@ip_address”.

NB: Under Haiku, “id” command returns “uid=0(user) …” so you should use “user” as username.


The ssh-copy-id tool does not take into account that the paths in Haiku are different. It will copy your key in .ssh instead of config/settings/ssh. Just move the key to the right place (or copy it manually directly to the right place using scp) and you should be fine.