[Somewhat solved] Can't compile using gcc on hrev57669 nightly

Is this a new issue?

/boot/system/develop/tools/bin/../lib/gcc/x86_64-unknown-haiku/13.2.0/../../../../x86_64-unknown-haiku/bin/as: unrecognized option `--gdwarf-5'

It should be -gdwarf-5 with one dash only IIRC

Where would I fix that though? It’s not coming from my makefiles

Could you give more context? How could it be reproduced?

With mercurial installed…

hg clone https://phab.mallen.id.au/source/lgi/ code/lgi/trunk
cd code/lgi/trunk/ide
make -f haiku/Makefile.haiku

In previous builds that just worked out of the box.

Maybe related to the GCC upgrade? CC @nielx.

What is the output of as --version ?

~> as --version
GNU assembler (GNU Binutils) 2.31.1
Copyright (C) 2018 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `x86_64-unknown-haiku'.

You need binutils 2.41 in combination with GCC 13.

Can that be upgrading in a running system easily?

pkgman update binutils

Ha that was easy…

But what’s the process of changing the default so that nightly builds work again?

I’ve created a ticket for this.