Some QT, KDE software interface using Chinese is a box, how to solve?For example,Notepadqq,QMMP

Some QT, KDE software interface using Chinese is a box, how to solve?For example,Notepadqq,QMMP.
I know it’s a font problem,but haiku is installed by default “Noto Sans CJK JP” Font, also, the QT-based software cannot choose the system default installed “Noto Sans CJK JP” Font.

Finally, after I installed the “Wenquanyi Micro Hei” font via repo, QT based software can select “Wenquanyi Micro Hei” font in the font selection interface and successfully display Chinese.


I think this is related

not yet merged repo?

It should be added as a patch to haikuports recipe since qthaikuplugins HEAD contains a bug which prevents clipboard from working.

Update qthaikuplugins package to the latest version and try again.

After update qthaikuplugins packag, it’s has been solved. thinks.

You’re transplanted QT、KDE software developers?
I found software have the following question : based on QT、KDE.
1、Maximization is based on KDE、QT of software, Haiku Deskbar will be covered by the software,But the original Haiku software doesn’t cover.
2、In haiku-X64 use Smplayer playing the video, it appeared a few windows, how to solve this?
3、Some KDE, QT based software, no language settings options, usually automatically acquire system language settings for the software itself language settings,For example:Calligra Suite not the language settings options,However, I have set haiku to Chinese, these software can not get my language settings, and can not automatically become the Chinese interface.How can I make these software into Chinese interface?

These are all known issues. Anyway, please file all of them at hopefully someone will look into them eventually.

BTW, it’s Qt, not QT (QuickTime) :slight_smile:

Yes. Thanks for your work.