Some games on Haiku

I have problems with some games in haiku.

In order i detail what is the game and what is the problem, i don’t know if they have some type of fix.

uHexen II (Hexen II Hammer of tyrion 1.5.8) The latest release 1.5.9.:

The game needs the timidity program which is not in haikudepot, and when i switch to fullscreen the game it gets on a black screen and the monitor sent me an out ut range message in the screen.


Has problems switching to full screen , but this time the game crashes.

Quake II:

Has exactly the same problem, it crashes when i switch to fullscreen.

Speed Dreams:
It simply crashes, i think the problem is related to the sound & music.


Works perflectly but on exit crashes and outputs a core dump. The core dump is on my haiku machine. I am posting now this on another machine using Windows.

I will send the core dumps and messages when i powered up the haiku machine an intel core 5 10600 with 16 megs of ram and an amd radeon rx580 8 gb motherboard an msi with b460 chipset.


If the games you’re talking about were downloaded from Haiku Depot, please create the respective tickets here Issues · haikuports/haikuports · GitHub

Usually, timidity is used via SDLmixer or SDL2mixer but not directly. Check if you have libtimidity and timidity_ freepats packages installed.

Hmm… Indeed despite timidity packages installed no music in Hexen II. It could be that there’s nothing to play. Only data of the demo are installed and you may need to copy data of the full game if you own it. Though, ‘Could not initialize timidity’ and ‘midi_drv: Disable at compile time’ are suspicious.

That is not correct. It has come with the demo
data that comes with midi files and that’s when the need for timidity comes into play. It has four modes to play music one from the original CD second from the folder of data and subfolder music with an mp3 / ogg files ripped from the original cd. But despiste the configuración always needs timidity because in the data files are midi files for the music. A part from that my concern is for the full screen Mode that don’t work and it’s something with Code that is not right, i believe.

That’s strange, I tried it in a qemu VM and full screen was working for me.

I tried on real machine and fullscren doesn’t work. Maybe you can try if you have different machines.

In you boot in UEFI using the framebuffer driver, it doesn’t allow to change resolution after boot while dedicated drivers are allowing it. Perhaps, it has an incidence on that too.

For midi, install wildmidi package, go to /boot/system/etc/wildmidi, copy wildmidi.cfg in /boot/system/etc and rename it timidity.cfg. Since it is a system folder, you will have to hold shift key to allow renaming. After that it should work, it does for me.

Not quite i boot in uefi mode but not with uefi driver as i think screen preferences show that i am using radeonhd driver.

And well , OpenArena switch perfectly well on to fullscreen mode.

I opened an issue on Haikuports about the midi problem. libtimidity package is missing config file · Issue #10275 · haikuports/haikuports · GitHub

Do you have music working now in Hexen II? Is that workaround also fixing your problem with Speed Dreams?

Anyway, for fullscreen problems, you should open separate tickets with details on Haikuports.

So, I tried Hexen II booting on an USB key and created missing timidity.cfg file as above.

Booting in legacy mode, I had no problem to select a video mode and switching to fullscreen. Played the demo few minutes without issue, music included.

Then restarted the system, this time booting in UEFI mode. The game is instantly crashing silently. Only later, starting it in a terminal, I could see ‘FATAL ERROR: No fullscreen mode available for this bit depth.’
I guess that deleting or modifying the game settings file would allow Hexen II to start in window mode but you would expect a popup reporting the error to the user.

The UEFI framebuffer driver cannot change video modes. This creates some problems if an application requires a specific fullscreen video mode.

This would be solved by having a native modesetting driver for your video card.

In legacy mode we are able to change video modes using VESA (to a limited list, but common modes for old games are usually in there).

1 Like

I understand that behaviour with my card that indeed use the vesa framebuffer.
IIRC it shouldn’t happen with dedicated driver and zantak has a radeon rx580 that apparently use radeonhd… Perhaps is it not the source of his issues.
I guess that we won’t know more before he opens tickets.

I am using a native modesetting driver (RADEONHD) and OpenArena switch correctly modes) but the rest of the games not. Maybe another problem with the driver?? I don’t know at least the driver works, desktop shows up.

If you have any debugging releases that makes logs onto the hard drive , i will use them for testing purposes. This possibly might help out for a solution. And thanks in advice for all your comments. I appreciate that.

Sorry but i can’t attach openarena coredumps and openarena reports when it crashes when exit is that i have in hand on my haiku machine.

Anyway, as already told in a previous post, it is not here but on Haikuports bug tracker that you have to report these issues.
Just describe your problems giving details on your setup.
If you don’t find details of the problem on syslog, what you can try to obtain more details is to start these games from a terminal.

BTW, I’m just a simple user just like you. As I have no skills for development, I try to help a bit with translations and here on the forum.

1 Like

Ok thanks for the help.
On github right??

Yes, except for few libs that are on Haikuports but are very tied to Haiku, the rule is to open a ticket on the bug tracker of the repo the package is from. You have the link in the second post of this thread. The idea is that someone with same problem will look there first.

So, I tested quickly Speed Dreams on a nightly. Indeed the game is not starting from the menu but is launching if you call it from a terminal (in some folder of the app). So, it’s probably a question of path. I will check later if it is the same on a beta.