(Solved)*.xlsx files not opened when clicked on, though LibreOffice is loaded

I have to open LibreOffice first and then open *.xlsx files. I tried to make it understand that it should be opened by LibreOffice,

But when I select the file to be opened with “open with” LibreOffice does not appear at all in list…how should I do this?

Please share your workaround.

Sorry…did not mean to clam up like that…thought it was too basic…I am still in learning stage as far as Haiku is concerned

There were many .ods files, which I had created while working on some project…I had rex filesceived files from others, which were in .xlsx format

Using ‘FileType’, I made the system understand that .xlsx should be opened with the same application used for .ods files

After this, it has marked all .xlsx files to be opened with LibreOffice spreadsheet

The first thing to do is to remove the sniff rule for zip archives in FileTypes. Because of this rule all xlsx, docx files will be defined as archives. After removing the sniff rule, zip archives will be defined only by file extension.

I checked in the “FileType” zip files are not listed…tried to add…but could not…
Can you please elaborate on what needs to be done?

setmime -set -sniffRule "" application/zip


Thank you very much. I will see what happens when other such file types need to be opened