[Solved] Unending pending after trying to reinstall mozc

I’m trying to install mozc. I first used pkgman on the terminal, but no input switcher appeared in the deskbar as it should according to this guide 雑記帳2022: Haiku R1 Beta3 で日本語を使う / Using Japanese in Haiku R1 Beta3

So I tried uninstalling and reinstalling mozc in haiku depot. Uninstalling worked, but installing stayed in the pending stage forever. Other packages are installed normally though. I tried restarting, but after, according to Haikudepot I never uninstalled it.

So after uninstalling with pkgman and restarting the system, Haikudepot accurately shows that’s it’s not installed, but when I try to install it, it still says in the pending stage forever.

According to pkgman though, mozc is already installed. Also, installing becjk through pkgman does add the input switcher to the deskbar, sometimes, not every time.

After reinstalling haiku altogether and installing mozc from haiku depot, the input switcher still did not show up in the deskbar tray. After installing canna and becjk, and restarting, the input switcher did appear after a minute or so, but without mozc as an option. mozc is in the methods folder though with the other two.

I can’t help you with your problem unfortunately, but just for better understanding of software installation on Haiku: pkgman and HaikuDepot do the same thing, they download and install packages. The first one is the commandline interface, the latter one the GUI variant.

Try removing manually the hpkg package from /boot/system/packages and search for instances within /boot/system/packages/administrative (but be careful there because those are system previous states and messing with that will prevent you from reverting a bad update).

It works for me on a reasonably current nightly 64bit. I did get a crashing app_server and/or input_server when re-installing right after uninstalling…

You could do a tail -f /var/log/syslog to see what gets written to the syslog. And also save the syslog from when it’s kinda working and when it doesn’t and open a ticket at Trac.

I’m not sure what I’m supposed to be looking for here. It’s been a while since I installed mozc, so I uninstalled and reinstalled it just now and this is what it gives me. Also, I’m not using nightly.
Also, it seems reporting bugs on specific packages from haikudepot is not allowed at Trac.

I have no clue what “libprotobuf” is, but that seems to be what’s causing an issue…

For 3rdparty software (eg. which comes from the HaikuPorts repo) the bugreports collected at https://github.com/haikuports/haikuports/issues

For me it seems, mozc needs to be rebuilt against the current protobuf (poissibly some fixes will be required, if the protobuf API not backwards compatible), or the protobuf recipe needs to be checked why the symbol is missing. It is possible that a configure-time option was not given, or some check fails because it doesn’t supports Haiku, therefore some features gets disabled, or some other problem along this line.

1 Like

Or, since it does work on (at 64bit) nightlies, protobuf was updated and the new built was not tested with beta3.
In any case, a bug report at haikuports is appreciated.

Checked on 32bit R1B3 with the current mozc from the depot, pulls in protobuf24 (as expected) and works fine.
A rebuild with the newer protobuf also worked fine for me here? (not checked 64bit though).

EDIT checked in a clean R1B3 64bit, install is ok but from syslog I saw this:
KERN: runtime_loader: /boot/system/lib/libstdc++.so.6.0.25: version "GLIBCXX_3.4.29" not found (required by libprotobuf.so.24)

Updating the system (and in this case gcc) solved the issue for me, so both arch’s on Beta3 are fine here.

1 Like

The reason could be the recent GCC version change:


GCC 11.2.0:

So protobuf needs to be revbumped.

Edit: revbump is done.

1 Like

I know (and mentioned on IRC earlier)

So I updated the system and rebooted it. Took me to debugland. I’ll try powering it on and off and see what happens.
edit: it works now


Great sucess!

@BlueHorse I think you created the issue at haikuports, closed this as it seems to be fixed, if not please reply there (or here) :slight_smile:

1 Like

This means the libstdc++ dependency should be explicitly declared, so that the required version is also installed.
see https://github.com/haikuports/haikuporter/blob/2f5df64165d9f58e005ad44b2e2251a2cef0761c/HaikuPorter/Policy.py#L213

1 Like