[solved] Today's update removed LibreOffice

During today’s update, it said some liboidb has to be installed, but Lo has to be uninstalled for this. I gave OK. It uninstalled LO and installed that package

After update, I tried to install LO from HaikuDepot
It now says no provider for liboidb >3.5…something
I am without LO now…

how to install again?

Install it from your previous state in /system/packages

not sure what happened to the package in haikuports?

After an update, I clean everything via filwip…so…previous system states not available

Next time don’t do that, the previous states exist for a reason.

You’ll have to wait for libreoffice / the dependency to be fixed.

Maybe create a ticket at the haikuports github if it isn’t known.

haikuports: new issue

Mmm, Ok… I see the problem:

  • LibreOffice depends on lib:librdf (from redland package).
  • redland depends on libiodbc.

And libiodbc got a fix on its recipe, as it previously had an error in how it declared the lib versions.

I’m assuming that just rebuilding redland should make it possible to install LibreOffice again.

Edit: fix already on its way. Either I or @Begasus will give a shout when is ready.


Should be fixed now, try again (or in a few minutes). Sorry for the noise :wink:


Good that it’s fixed, but surely installing an earlier nightly would have been a simple solution if it hadn’t been.

It wasn’t a problem with haiku but with the haikuports repository, installing a previously haiku version would not have helped.

The main problem was wrong library version provided by the libiodbc package, this was fixed a few days back, also turned out that the redland library (needed for LO) didn’t need that package anyway, so that dependency was removed to fix this. Happy writing :wink:

Thanks to you and Begasus for explaining.

1 Like

Today, again I tried to install LO from haiku depot. It said it will install some redland package first. I said OK. Later, it downloaded LO files…for a long time, ‘installing’ message appeared at the bottom left corner. waited an hour…installation did not complete.
Haiku depot says pending, LO not displayed under "Applications’
Any further suggestions will be taken gladly

It’s possible something got stuck inside HaikuDepot.

Reboot, and try installing on the command line with pkgman; see what happens then.

Removed libre office and installed via terminal, as you suggested…works fine now



LibreOffice disappeared on my system too.
I installed it on the command line
with pkgman install libre office
and it reappeared.
I checked it three times afterwards,
once it acted rather weird and it froze,
but now it works well.

By the way, it’s strange how fast libre office was installed!
On GNU/Linux systems it takes a few minutes.
On Haiku it only took a few seconds!?!?

This time it wasn’t me :wink:

1 Like

Most probably because after it disappeared, its packages were kept in one of the “state_2023_04_[…]” directories under “packages/administrative/”. After the dependency issue got resolved, pkgman was able to reinstalled from there (instead of re-downloading, as those files actually matched the ones in the repos.

Besides that… Haiku only needs to download/install one file, while on most Linux, installing a package implies unpacking it, possibly creating LOTS of files (that can take a while, even if the files are small, but plenty).

I think people should pay a bit more attention when updating their systems. Both pkgman and HaikuDepot will clearly show if something is about to be uninstalled (for example) before it does.

If you see something “weird”, like… “This will remove LibreOffice”… you can simply cancel the update, and try it later.

Just my 20 pesos (inflation goes brrr).

At least you still had the .hpkg files available, makling the issue, eh… less of an issue :slight_smile:


Very useful information.
Thanks BiPolar.

I update my system once a week ,
using the SoftwareUpdater.
It just shows the packages that will be installed and I just press yes.
No suspect message had appeared though.