[SOLVED] Thinkpad X40 - Alpha 4 freezes on boot, previously worked fine in Alpha 2 & 3

I’m having trouble with installing Alpha 4 on my Thinkpad X40. I am eager to use the WPA wireless so that I can actually test it out in daily use. I try booting from the CD, and it freezes when you see the Haiku logo. It only gets to the HD icon.

I burned an ISO, tested it on my desktop, works fine. But, I don’t have wireless in my Desktop. I tried to boot the CD on my Thinkpad, which has previously worked with Haiku Alpha r2 and r3. I’ve previously booted with USB CD-ROM and USB sticks. So it is not a problem with the media. How do I get the error codes to know what is not working.

X40 Thinkpad
CPU 1.2 GHz Pentium M
MB bus speed 400MHz
HD 8GB USB + 8GB SD Card
WIFI Atheros AR5212 / AR5213
GPU 64MB Intel Extreme Graphics 2
1024 x 768 XGA LCD
OS - Linux Mint Maya 13

-OK, I figured out what the problem is on my laptop. Since the hard drive has been broken, I forgot I had changed the BIOS so that it would skip the hard drive. Linux Mint would keep trying to do a fsck on the hard drive before it would finally skip it and boot from the USB. But Haiku seems to ignore it and boot.

I just have to remember to change it out if I go back to Linux Mint later.

During boot press SHIFT to enter the boot menu, where you can configure the safe mode options. That might help to boot further.

Then, please read http://dev.haiku-os.org/wiki/ReportingBugs

In case you can’t find a ticket at http://dev.haiku-os.org/ that matches your problem, please file a new one and attach the file /boot/common/var/log/syslog to it.

Without you telling where it stops and showing a screenshot/photo of it it is not possible to guess.

I would recommend to open a ticket at https://dev.haiku-os.org and attaching there all of the relevant information.

You can also try older nightly images using binary search technique:

I think I figured out the problem. If you guys look at what I listed for Hard Drive, you will see the reason. I am using one of those micro USB cards for the OS, and a SD card for storage because my HD is dead. My Thinkpad was an Ultrabook before it was cool to be an Ultrabook : ) It’s super small and uses a 1.8" HD ($80.00) that I don’t want to spend the money to replace.

I first tried the fail safe video, thinking it might not correctly identify my video card. But that still froze the install (see picture below). Then I booted safe mode, disable IDE DMA seemed to do the trick. I’ll post again and give an update.

EDIT: Only wants to boot with disabled IDE DMA, but this makes it run slow. Any ideas or am stuck with this because I don’t have a working Hard Drive?

You need to create a ticket first, developers rarely read forum posts.