Solved -- Running Haiku install in Bhyve

Morning all.

Running Haiku in a Bhyve system seems to work great – up until I get it installed and then have to run the bootloader into Haiku. At that point, the Haiku boot loader says that the install is not compatible. Host is FreeBSD 12.2. Edit: Haiku is R1 Beta 2.



I’m using UEFI because Bhyve seems to require it, and I used both the “UEFI Booting Haiku” and “Emulating Haiku in Bhyve” guides, but neither seem to address this particular issue.

I’ll note I was able to get the “UEFI Booting Haiku” method to work in getting Haiku onto bare metal, but due to resolution issues, the ability of Bhyve to modify the framebuffer resolution makes Haiku far more useable than the 1280x1020 resolution is on my 4K monitor.

Installation steps? Sure. I initialized the Bhyve partition (truncated file, though I’ve also tried with Zpools) with GPT, created a 32mb EFI partition, formatted it Fat32, filled the rest of the space with a BeFS partition and run the installer there. I then went to the desktop and copied the live CD EFI folder to the EFI partition.

This process worked fine on bare metal but in Bhyve? Not so much.

I prefer Bhyve because it seems to run Haiku (at least the live disk) far, far better than Qemu or (especially) Virtualbox do.

Anyway, if you can help me get Haiku’s bootloader to recognize the Haiku Bhyve partition, that would be really appreciated. Thanks.

Going to mark this as solved, as it seems that if you use the latest nightly build it boots just fine in Bhyve. I’ll leave this up for reference for anyone else running into this problem. Thanks for reading!