[Solved] PCIe wi-fi card TP-Link TL-WN881ND displayed under devices as RTL8192EE, but wi-fi network not recognized

Installed a PCIe wifi card, TP Link 300MBPS TL- WN881ND(EU) Ver.2.0, on my desktop, with 2 HDD, slackware14.2 on one, Haiku on another. Slackware recognized it out of the box, wifi networks shown…
When I booted into Haiku, wifi networks not recognized.
I checked under ‘devices’. This card is shown as Realtek Semiconductor make, RTL8192EE PCIe wireless network adopter. So, hardware OK. Why is wifi not recognized? Card image shown during boot up screen display
Are the drivers not present? Atheros 9K or 8K drivers should work, I think I read some where to that effect. CD with drivers given to me along with the card, but can we install drivers from that? Pl. Suggest what should be done…
I bought this card only for Haiku, since earlier it was clarified to me on these forums that USB tethering to Android will not work. Before this card was installed, I used USB tethering to Android, on slackware

Because Devices only lists devices, whether they have a driver or not. PCI devices have classes which tell if they are video or network devices, and vendor and device IDs, which are shown, but this doesn’t mean they will work.
You should check which FreeBSD driver works on it, maybe it only needs the PCI IDs to be added to the source code.

In which source code should it be added? Can I, an end user, do it? Will it permit me?

This is not the case; Realtek chipsets have their own drivers, namely the rtwn driver on FreeBSD which is called realtekwifi under Haiku.

The 8192EE is supported, I think? So if it is not showing up, please submit a ticket about this to the bugtracker.

I hope I have made clear the issue. RTL8192EE shown under ‘devices’ but not visible in 'network, or ‘network’ status

Filed a bug report as suggested…I have to wait
Waited for PCIe card to arrive, now for it to work…
Entry to Haiku has not been exactly ‘awesome’
Grin it and bear it…

When I type ‘iwconfig’ in bash, it says ‘command not found’

try ifconfig?

Ifconfig shows only wired LAN. Qualcomm atheros gigabit card AR82 something…

Win XP drivers for this? OMG! wtf?

listdev in Terminal

device Network controller [2|80|0]
vendor 10ec: Realtek Semiconductor Co,…Ltd
decice 818b: RTL8192EE PCIe wireless Network Adapter

Pl. refer bugtracker. syslog attached there

1 Like


listimage in Terminal
Kernel -> wifi driver ??

When I type ‘listimage’ in terminal, I get along list. Not as in your screen shot.

unable to upload the file for listimage as .txt. says only .jpeg, .png, .giff permitted

I never test it but try in terminal “listimage > output.png”. It runs with text file.

Tried. It created output.png file. Nothing inside it

listimage in Terminal
Kernel -> wifi driver ??

Please check. Camera shot from mobile…posting from mobile
No mention of kernel wifi drivers

Any further inputs