[Solved] No sound on a Dell Latitude notebook

I tried to blacklist the hda driver after installing OSS with no succes. I still have no sound.

~> listdev | grep Audio
device Multimedia controller (Audio device) [4|3|0]
device 1c20: 6 Series/C200 Series Chipset Family High Definition Audio Controller
~>

Any help or recomandations are welcomed.

Hi @stefanlnte, welcome to the Haiku community!

Looks like there already is a ticket in the bug tracker for this: https://dev.haiku-os.org/ticket/17170

Do you have another OS on this machine (Windows, Linux…) where the sound chip is working? If yes, you could try to boot into that OS first and then do a warm reboot into Haiku and check if the sound is working. Not really a practical solution but if it does work (with the hda driver, that is) please report it on the ticket I linked, it might help the developers find the problem.

Regarding OSS, did you check that you disabled the hda driver correctly? Blacklisting is explained in detail here: Disabling components of packages | Haiku Project . It’s important that not both the hda driver and opensound are active at the same time.

Furthermore you can upvote the ticket in the bugtracker. This doesn’t guarantee anything of course but might improve the chances of the ticket getting worked at.

1 Like

I guess we all have our fields where we are comfortable, glad to see you stepping in here (and other reply’s too) @BlueSky ! :ok_hand:

3 Likes

I do not have dual boot installed. I will try to disable the hda driver again. Thank you for your answer.

1 Like

You could also boot from a live Linux distro on USB stick and then reboot. I used to do this with a laptop that just had Haiku installed but the same HDA init problems.

I booted another OS where there is sound. The problem remains. No success with disabling the package. Thank you for your time.
screenshot1

After disabling it I still get two drivers
3019 0xffffffff807ae000 0xffffffff807bb000 0 0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda
3055 0xffffffff8190a000 0xffffffff8190b000 0 0 /boot/system/add-ons/kernel/drivers/dev/oss/oss_loader

Actually it’s

Package haiku

not

Package hda
3 Likes

Thanks . It worked. I have sound.

7 Likes

Thanks @Begasus, I’ll try to help where I can. Only giving back a bit to an amazing community that is always very helpful and friendly to me. :+1:

1 Like