[SOLVED] No boot on Ryzen + RX 590

Hello, things I know:

  • There is not driver for RX 590, I have to use VESA.
  • I have to boot with EFI
  • NVME driver is somehow broken (?)

I’m trying to boot from a usb drive but not matter which options I use (safe mode graphics, disabling specific drivers, etc) the computers reboots itself or just hangs on the haiku logo (without loading anything) and power off usb devices (so ctrl-alt-delete doesnt reboot the pc and I have to cut power)

Any ideas?


In the boot menu, enable on-screen debug. Then take pictures of the displayed text as the machine is booting. Submit the result in a new bugreport to dev.haiku-os.org. Then we have some chance of identifying a problem.


1 Like

I’ve enabled on screen debug but it never show any logs. It either reboots or hangs.
I haven’t filled a bug report because I don’t have any logs at all.

So it don’t light any boot icons? Than it may be a problem in Haiku boot loader.


First at boot your machine must hold on a space bar, next you see a screen
You must a choose a correct option, safe mode first
Next you maybe a enable a debugging and logging
For automation for until once boot you must a prepare a file look @ screen

I’ve got Ryzen 5, RX580 and NVME drive as well. All boots fine if I select failsafe graphics card driver option in the bootloader. Maybe some other hardware causes issues? What do you have there? What Haiku build are you using? Is Haiku already installed or are you booting from USB stick? I had some issue with low quality stick before, switched to a different one and it went fine afterwards. Also some daily builds may be broken.

Those are my specs. I’m trying to install from the usb, I’ve never booted haiku on this computer.

The same thing happens with the latest nigtly and the beta: it hangs on the haiku logo before lightin up any modules or it reboots the computer.
I have tried with another usb stick and it had no effect.
I have confirmed that this usb stick boots haiku on a Thinkpad x230 at first the bootloader showed this:
and then I have to reselect Boot volume haiku but it boots fine to desktop.

I guess I’ll do a lspci on linux and open a bug with that info, since my hardware should work.

It is anecdotal a bit but I just booted Haiku hrev53839 (which is pretty old, but I didn’t bother to update the USB stick) on my Ryzen 2700 system. My motherboard is the MSI B450 Tomahawk Max, with 32 GB of RAM and a Radeon RX 5700 XT graphics card.

It booted fine and I even have 4K resolution, though I think it is still just the VGA driver. The monitor is connected with DisplayPort.

Sound and ethernet work, I am playing some music from Youtube, obviously posting this from WebPositive.

Seems like you have two monitors connected, I’m not sure that would cause a problem but it might, so maybe try disconnecting one?

My computer booted haiku, finally. I still don’t know what the problem is but at least I know the cause.
When I power on my computer I press F12 to open the boot override menu, I select the usb stick to boot haiku. When I do that what happens is what I explained before.
But, if instead I go the BIOS and configure the usb stick to be #1 priority to boot from and power cycle my pc haiku works fine.
I supposed my motherboard’s bios is doing something weird when you boot from F12 menu and the haiku bootloader don’t know how to deal with that (maybe some unitialized devices?)
Thanks for all the help.


I’m seeing the same weird behavior on a Ryzen 7 1800X, this is with hrev55507.

If the usb-key is the first device in the boot order it boots perfectly fine, but if I boot haiku via the F12 bootmenu it stalls before lighting up any icons. Via bootmenu I can only get it to boot by selecting “Ignore memory beyond 4 GiB” in the haiku boot menu.

I know this was solved, but does Haiku need any more testing on Ryzens and/or their integrated graphics? I’d be happy to test it out on my main PC and any other working PCs I have.

Ideally, test it on everything you can.


Good day @leavengood,

To get sound to work on that machine what did you do? I’m on Ryzen too, but never got sound working, coming out from the display I mean. Do you have external speakers?


I had sound with external speakers. I don’t recall if I tried the headphone jack, but I’ll try that next time I test Haiku. Sound in a monitor won’t work yet as Haiku does not have support for HDMI audio.