[SOLVED] Need Help Putting Finishing Touches on a Bare Metal Install


#1

I recently got Haiku 32 bit installed on an old laptop. I went into the BIOS and disabled UEFI and put it in legacy support mode, and booted from a Haiku USB stick. I partitioned (intel partition), formatted and installed.

But when I tried booting from the install, it said no bootable disk found. So I booted with the USB stick again, installed the boot manager, and set it to go into Haiku immediately. This worked, but the problem is, the boot manager always flickers some text on the screen before the Haiku boot screen shows up. This doesn’t happen when booting from the USB stick. How do I get my Haiku 32 install booting as visually clean as the USB stick?

The other finishing touch is that while I was first checking out Haiku, I was running in virtual box and installed quite a few packages. I’d like to migrate these over to my “real” install instead of spending all that time and bandwidth re-finding and installing all those software packages. Unfortunately, there doesn’t seem to be a way of easily identifying what packages are standard system packages and which are the result of the installs I did with Haiku Depot (the ones I chose, plus all of their numerous dependencies). Has anyone else done this?


#2

You can use Installer and it will copy most of your system state, including non-default packages you’ve installed. Or you can just copy all contents from packages directory to the new machine.


#3

Well, I had to use the anyboot image and put it on the USB stick using Etcher, because Installer kept hanging while installing onto the USB stick.


#4

(NOTE: I’m doing all this experimental stuff inside a virtual box vm)

I just tried the latest build (hrev53000). And Installer didn’t get even as far as it did before. This time it failed while it was in the middle of writing files from my Home folder to the USB stick. It didn’t hang, but it failed with a Bad File Descriptor message.

When I tried examining the USB stick, I discovered that it looked as if it had wiped out the partitions. I rebooted the vm, inserted the USB stick, and the volume looked fine. It just had a partially populated Home folder.

What about the Haiku hpkg’s that are definitely part of the operating system? Is it really safe to just overwrite them?

Update: I just tried copying the packages onto my USB stick, and I got this error:
VirtualBox_Haiku32%20Nightly_18_03_2019_23_56_35

Notice that it’s complaining about trying to copy a file that was not selected and dragged over to the destination folder!

Scratch that, It’s another file that should have been in the group I deselected… going to look into this. Back in a moment.

OK, It must have been something in the Administrative folder. Is it OK to not copy that one over? Or is there some book keeping information that has to be brought over along with the hpkg’s?

Just for giggles, I tried leaving out the Administrative folder. Same error message just happened when writing a different file.


#5

You can rewrite the boot sector for your disk using the “writembr” command. Also make sure the partition you install to is marked as active (there is a checkbox for that in DriveSetup when creating it). Then it should boot without problems and without flashing the boot menu.


#6

Thanks! That took care of the booting issues.

Now, to fix the packages. How well/stable is ftp file sharing currently working? Will ftp preserve BeFS file attributes of the hpkg’s if I copy them that way?


#7

HPKGs are entirely self-contained, they do not have any attributes on the files that must be preserved. You can store them on any file system you want.


#8

HPKGs don’t have any extended attributes so copying them to any file system (or via ftp) works. Maybe your USB stick has some defect.

Try running tail -f /var/logs/syslog in Terminal to see if there’s any interesting info in it when you try to copy stuff.


#9

I got all the hpkg’s transferred and installed. It turned out part of the problem was the extension pack with USB 2 & 3 support wasn’t installed in virtual box.

But before I got them moved over, I tried doing the natively created USB installation stick. It didn’t go that well: First, it replicated everything in the installation running in the VM, including a huge number of files that made up a number of vcs repositories (>180K files!!!). It took hours to make that stick. When it finished, I used it to do a fresh install onto the old laptop. Both the USB installer stick and the installation it created took forever for the boot progress screen and icons to show up (atom, disk & magnifier, etc…), Much longer than the it did before when I used the anyboot iso flashed onto the stick using Etcher. It was so bad that the install stick was immediately reflashed with etcher, and yet another fresh install was done. I copied the hpkg’s onto another partition in the extra space on the USB stick and transferred them that way.

I still had those version control repositories to transfer, about 8.5GB of them. I tried copying them onto the USB stick, but that many files was going to take hours again, so i decided to try ftp. Big mistake. First it was going to take hours to transfer that many files even using ftp (I was only getting a max of about 1.2MB/s!), then I tried making a tgz of all the repos which “only” took a couple hours. But then I ran headlong into network problems over wifi. The ftp transfer kept stalling permanently after about 140MB, give or take a few MB pretty consistantly. So, after ftp was a no-go I went back to the USB stick and copied the tgz of the repos onto the extra partition, and transferred them that way.

Once the repos were on the bare metal install, I tried updating all of them (they were a couple days behind at this point). That when I discovered that it wasn’t an ftp issue, but a general (wifi?) networking issue, because the vcs tools (git, mercurial, etc…) were intermittently failing and reporting the reason as being failed dns lookups.

So something is still wrong in the networking: dns lookups were failing, but so were ftp transfers over a local wifi network using raw ip addresses. The wifi driver(?) Haiku is using on the laptop is reported as the “realtekwifi”. Is this a known bug? Is there anything I can do to help (log files, etc…)?


#10

You can look through the Bugtracker for similar tickets (and file a new one if there’s nothing) and add syslogs and other info, see the bug reporting wiki.


#11

Since the two problems I was having with the bare metal install are taken care of, I’m going to mark this as solved.

I’ll look into my problems with the realtekwifi in the bug tracker, and possibly start a new topic or ticket.

Thanks for all the help with the install!


#12

If you are actually connected, the WiFi driver is not the problem here. We don’t do “local” DNS resolution at all yet I believe.


#13

Ah, I see now that using raw IP addresses didn’t work either. Possibly DHCP failed, or the driver broke; if you were on the beta, there were quite a number of fixes to that driver since then in the nightlies, at least @cb88 says it works for him now.


#14

I’m running hrev53001. One of the first things I do after installing is run software updater. Sometimes two or three times if the download fails.