[SOLVED] Manually fix "No boot partitions found" issue

My bare metal install is giving this error on each boot, then I have to go and select the partition manually. Is there a way to fix this?


Have you seen this thread:

You may have to update your EFI bootx64.efi file if the existing one is over 12 months old (of so). Its to do with an update to the packages being compressed (and boot loader needs to support this), and recently it was turned on. Any EFI image installed in the last year supported this. If your EFI system is older than that, then its time to update that file.

1 Like

I had the same exact issue. Maybe it’s related to the same underlying cause.
See Could not find boot partition which include also the solution that resolved the problem for me.


I had a different behavior where the partition was set to “linux” type, i was able to boot just fine, but running checkfs always got me in KDL, tried to change the type but it just silently failed, so i had to do a clean install.

@Zenja, this is a new install, the bootloader was the up-to-date one.

@javanx, this worked like a charm! Thank you very much!