SOLVED -- Losing replicants - and annoying, slowly way to restore them

Ahoy Haikunauts !

On my desktop I have some replicants added to show stuff and help me using Haiku. I like them.
Unfortunately Haiku time-to-time destroy them. I just do not have them back after a shutdown and boot the machine later.

What I could do earlier ?.. I found the progs contains them, created the replicants onto desktop again - manually - and placed them back where I like to be placed …
After a some iteration it became very-very annoying … so I decided to read the ‘User Guide’ and it was good …
I was red the file ‘tracker_shelf’ and that hint :
if I remove it – all replicants would be removed …
Ha-ha thanks … Haiku does that automatically – I would like to have the opposite : an instant restore or at least a lesser painful !.. :((…
Ok, so then I thought :

  1. I keep it elsewhere if all replicants are rightful and placed as expected,
  2. copy back if shit happens
  3. restart Tracker or reboot Haiku if copy back in itself does not help !..

Well NOW … shit happened - all the replicants had gone again - I started to restore them in the slow, manual way … when I wanted to check it in ‘User Guide’ … it was done again … and then my leakege was patched and finally remembered I had kept a a ‘tracker_shelt’ already some monthes ago … so come on : follow pont 2) and 3) !

Ok, so point 2) (copying back ‘tracker_self’) was done flawlessly under Tracker settings …

the problem started right after that … execute point 3)

Have the Tracker use the restored ‘tracker_shelf’.

(Now I finally understood why that little puppy is on its icon …)

After some failed attempts I felt myself as a cartoon hero that just frustrating and histerically angered themselves on a kind but cunny and intractable opponent

NOW Haiku (Tracker, the mean-spirited puppy !..) could guard the ‘trackewr_shelf’ (stubbornly do not let its swacky bone)
NOW when I wanted to replace it with a healthy one …
NOW It was instantly written back with halfbacked one as Tracker restarted … Or Haiku rebooted …
(possibly from memory area … Aaaaaarrrgh ! )

I tried to click on saved ‘tracker_shelf’ file … maybe Tracker re-read it as Terminal settings file reset back Terminal settings … unfortunately nothing happens …
I changed its setting of Opening application relation :
from ‘Default program’ to ‘Tracker’ …
… it had not helped … CLICK and nothing happened :((…
This way I changed back to ‘Default program’.

So, finally I gave up …
I get the replicants back
again
in manual way …

Man, I’m kind of lazy man who is stubborn to keep an easygoing restore the favoured settings back
and
furiating me if such things
what should have work as expected
just does not work due to their weirdo inner logic or mechanism.

On top of that I lost ‘System Volume’ from the systray so I cannot get its replicant back …

Anyway - if someone know some trick or hint how can I use the saved state to simply restore my Desktop with all the replicants …
…without all the manual labor …
I would be appreciated -

… a lot.

EDIT #1 :

At least I could figured out - I can resize Process Monitor window, and that way the charts are bigger now I mean higher, thicker, so drawings seen better, not so thin bands as earlier.

EDIT #2 :

At least I could restore the sound volume and its replicant.
I found - using User Guide – the ‘Media’ preferences contains the mixer settings. So I could add sound volume back.
Now the Desktop is back - as expected.
Until next accident :((…

Tl/dr
Did you write all this for lost replicants that you did recover so in the end there is no problem???

While the disappearance of replicants should be investigated, to determine if it is from something that happens in your machine, or a bug, restoring the file should work.

If you can try, maybe using a bootable usb to restore the file, just to see if it is a matter of it being in use by Tracker when you try to copy it ?

I’m not sure that this file tracks replicants that are loaded. It’s probably only their settings.

I’m not sure I understood everything in that essay…
Anyway, what may be the problem when restoring or backing up tracker_shelf is that Tracker saves the file when quitting. A way to successfully do that:

  1. Configure the Replicants to your liking.
  2. Quit Tracker, e.g. with ProcessController’s menu “Quit an application >”.
    → Tracker saves tracker_shelf and auto-restarts.
  3. Copy /boot/home/config/settings/Tracker/tracker_shelf to somewhere save as a backup.

Now, if you lose your Replicants you restore it:

  1. Copy your backup tracker_shelf to /boot/home/config/settings/Tracker/ thereby replacing the “de-replicanted” version.
  2. Kill Tracker - don’t quit or Tracker will overwrite your restored tracker_shelf with its “de-replicated” version again - e.g. with ProcessController’s menu “Threads and CPU usage >” clicking on the Tracker entry and confirming Kill this team. (Or use the Vulcan Death Grip™, see the User Guide).
    → Tracker will be auto-restarted without having the chance to overwrite your restored tracker_shelf and the Replicants are back.

No, no, it tracks all replicants all right. Have a look in Terminal with:

 message /boot/home/config/settings/Tracker/tracker_shelf

Yepp, should work … just as I wrote.
It just does not work … again.

Now I have the file from the time when I shutted down in the early morning … however there are no replicants … again.

I had restarted Tracker by killing it – it had reseted the file ‘tracker_shelf’.

~> cd ~/config/settings/Tracker/; ls -ltr
total 30
drwxr-xr-x 1 user root 2048 nov. 14 2022 ‘Tracker New Templates’
drwxr-xr-x 1 user root 2048 nov. 23 2022 DefaultFolderTemplate
drwxr-xr-x 1 user root 2048 nov. 23 2022 DefaultQueryTemplates
-rw-r–r-- 1 user root 0 nov. 23 2022 FilePanelSettings
drwxr-xr-x 1 user root 2048 nov. 23 2022 Go
-rw-r–r-- 1 user root 0 nov. 24 2022 MostUsedMimeTypes
-rw-r–r-- 1 user root 0 ápr. 27 04:11 OpenWithSettings
-rw-r–r-- 1 user root 213 szept. 19 15:02 tracker_shelf
-rw-r–r-- 1 user root 546 szept. 19 15:02 TrackerSettings
~/config/settings/Tracker>

This way I cannot hope it just simply reread it. Stop and start Tracker … can initialize the file in some certain cases. For example at unexpected end and killed process. Those cases are understandable. But after a normal shutdown and boot … strange.

I hoped in an answer that based on
I can force Tracker somehow to reread the file and have all of them back quickly.

Not really the why is interesting for me. I had more occasion when Haiku stucked so I had to use the power button and against that the replicants were as it was before … after the restart.

I lost them mostly when I shutted down regularly - it does not happens frequently, so this way I would like to know rather quick restore than investigate : why ?.. it just generally unexpected.
And take longer time … every times … to set back.

Anyway, thanks for your confirmation and suggestion to investigate. I may do later. Now I would be happy with a quick way to restore : when it happens.

Dear @humdinger ,

My problem is : I restarted Tracker by killing it with Graphical process Controller. Against it the file was overwritten - so it seems I just thought it kills.

I would try CTRL+ALT + DEL option now - I will see what happens.

Dunno what’s going on then. I used to successfully backup/restore tracker_shelf as described repeatedly in the past, when there was no package management and updating meant installing a fresh ISO.

1 Like

Thanks - this way worked.
So in Process controller … just clickimg on a program really just regularly stops it against kill it … good to know.
I thought it kills them as they used to be instantly stopped , but some of them also restarted as well.

Thanks - this was the missing piece in my puzzle- now I have the quick restore solution.

The last question would be …

I did in Terminal
kill -9 PID of Tracker process

Why it had not worked ?..
Because I really just tried to kill a thread … not a whole process aka Team in Haiku ?

kill Tracker works

I made some shell scripts:

https://fatelk.com/replicant-tools.zip

Thanks – I use ps this way already … I mean naming the program.

So this kills team in terminal - thanks. I must refactor my stuff what I think about “processes” in case Haiku.