[Solved] Kernel Panic installing to USB Stick


#1

I booted from the 64-bit live DVD and followed the steps to set up a 64 GB Lexar USB stick with the Be file system using DriveSetup. I selected the destination from the installer and let it rip.

it showed the progress bar and worked through about 400 of the files out of the 400+ it was showing. I could not see the exact number as the KDL over-wrote almost the entire screen (I have a poor memory and could not remember the actual total). In any case, once it reached that point, Haiku crashed.

This is not the “no partitions found” problem. The first two lines before the “Welcome to Kernel Debugging Land…” are:

bfs: bfs_start_index:2177: No such file or directory
PANIC: SMAP violation user-mapped address 0x000000e35d4b1450 touched from kernel 0xffffffff801448e5

After the “Welcome…” the next two lines were:

Thread 1025 “makebootable” running on CPU 2
stack trace for thread 1025 “makebootable”

And then the various dump stuff.

I attempted the install twice even though (I think it was Einstein) said doing the same thing over again and expecting a different result…

NOTE:
The LED on the USB stick continues flashing until I reboot (or unplug the USB stick). So it is being accessed, but I have no idea what is happening.


#2

At boot hold shift and disable SMAP and SMEP in the bootmenu.


#3

Please take a photo and post it to the bug tracker (https://dev.haiku-os.org/). Thanks!


#4

Tried the Shift key which seemed to work once (i.e. to get me into a boot screen), but could not see anything about SMAP or SMEP. So I tried a search (here) for SMAP and SMEP and found the answer in another thread… I needed to hold down the space bar (not shift) to get the right boot-up screen.

Disabling SMAP and SMEP did allow the install to complete — thank you.

However, when I attempted to boot from the USB, I ran into another problem. I will retry it (I didn’t record the error message) and then do another search. If I cannot find the answer, I will create a new post (to keep unrelated issues separate).


#5

@extrowerk’s solution worked, so presumably it is a known problem.


#6

It is not a known problem, the solution you mentioned is a workaround, that is it disables the security check. Please post a bug report, if it still happens after updating.