[Solved] Install to USB stick - Missing operating system


#1

Having resolved several items with help from forum members, I’m now at the point I want to be able to run a persistent version of Haiku from a USB stick.

I boot into Haiku from a USB attached DVD drive and do an apparently successful install to a 64GB Lexar USB stick. When I attempt to boot from the USB stick I get the following (presumably from the computer’s firmware):

Missing operating system.

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key_

I rebooted into Linux (Mint) and used gparted to check that the boot flag is set (it is).

From the various threads I searched, I assume this is some kind of problem with the format of the USB stick, such as: the bootloader was not installed, the bootloader was installed but cannot be located, there should be another partition on the USB stick with something in it…

When I looked at the DVD using gparted, I noticed it has a small “efi” partition after the Be partition. The USB stick does not. Is this a problem?

Any assistance would be appreciated.


#2

If your hw set up for efi boot, then yeah, thats a problem, but for legacy boot it should not have any influence. Check your bios/firmware, and set it to legacy (warning, it will render other efi os unbootable, for booting them, you have to switch back to efi boot in the firmware).

Or, if your other os needs efi/uefi, you can manually create the required efi partition on your usb and copy the efi binary there (manual means really manual, efi bootloader install is not yet automatized). I assume there is a documentation somewhere online how to do it.


#3

If just setting Legacy boot doesn’t work right, you may have to play with the CSM (Compatibility Support Module) settings, also.


#4

@extrowerk and @MrEntropy: I checked my firmware settings. There is a “Legacy Support” item in the Boot Options that can be set to “Enabled” or “Disabled”. It was set to “Enabled” which I have not changed. There is some rudimentary “help” text that shows up when an option is selected (“Item Specific Help”). It says:

When Legacy Support is enabled, BIOS will load Compatibility Support Module (CSM) to support Legacy OS such as Windows 7, Windows Vista, Windows XP and DOS. When Legacy Support is disabled, BIOS will boot in UEFI Mode without CSM to support newer OS such a Windows 8.

You can tell I did not purchase this computer this year!

In any case, since I cannot boot, I assume from your replies that I will need to try some options in CSM settings (I will spend more time looking at the BIOS/Firmware settings to see if there are options there I can tweak).

I suspect the best option, if not the quickest, is for me to set up an efi partition and copy the binary there. I will search for instructions on the “copy” part.


#5

I have reformatted the USB stick and it now has an EFI partition; however, I do not know where to get the file(s) (or how to create the file(s)) that belong in that partition.
An Internet search just leads me to discussions that seem to go around in circles. …

It seems to me that some kind of bootloader should be stored in the EFI partition and that bootloader must know how to chain to Haiku’s bootloader. So just copying a random xxxxx.efi file to the partition doesn’t seem right. The simple presence of an EFI partition flagged as bootable and efi is not sufficient (I tried it :roll_eyes:


#6

If you still have the install media, you can use Linux to mount the EFI partition and use the files inside of there to move to the USB stick.

You may get an error if you let the GUI try and mount it, but you should be able to do it with a terminal with the mount command.


#7

According to your comment above you don’t need efi, you were trying to boot from a legacy system, that means you were doing it right, now just reinstall haiku the same way you did it the first time but before rebooting open a terminal a write the mbr to the usb stick, i assume you didn’t know about this last step?
So in your teminal type:

writembr /dev/disk/usb/0/0/raw

Just make sure you don’t have any other usb sticks plugged in when doing that.


#8

@khallebal : This worked perfectly - Thank you!
The problem was the missing write of the MBR. Presumably, at a future date, this will be done automatically by the installer (perhaps with an option to do it or not).


#9

Yes, i think that’s the idea, it’s just that there are so many things to do and so few devs that this one among other things is left a side for now.
Glad i been of some help.